Moto G6 Not displaying folders when connected to PC


What phone do you have? Motorola G6

What plan are you on? MyChoice +1gb

Does your plan include data, or just talk & text? has data. still 1gb left to use

Issue Description

My Laptop successfully installed the device drivers and AutoPlay started. I clicked the option to display folders in windows (V7). The device itself shows up but no + on its left to expand folder list. Clicking on the device name does nothing. I rightclicked and tried to import photos and videos. I have several photos on the phone but that process said there was nothing found.

I never had this issue with my Moto E2. What do I have to do differently with a G5?


Go to the About Phone entry under Settings
Touch the Build Number Field 7 times to get into Developer Mode.
Click the Back Button.
You only have to do the previous steps one time.

The following is not saved as it seems that the G6 defaults to only charging when plugged in by USB. But it’s nt a big deal.
Go to Home Screen and Pull the Quick Screen from the top of Home Screen.
Look for Android System USB Charging this device at the bottom of the list.
Click on it and click again.
A Menu appears,
Select either Transfer Files, the phone will be treated like a Thumb Drive. Which is what I want.

There. I shared the solution I was was given elsewhere.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.