Moto G6 Play unable to receive texts after latest Messages app update

What phone do you have?
Moto G5 Plus running Android 8.1.0
What plan are you on?
My Choice Plan
Does your plan include data, or just talk & text?
Yes, it includes data


Issue Description

I have numerous text threads in the Messages app with individuals, multi-person threads (both Republic Wireless customers and customers of other cell services, e.g., Verizon, and using Android or iPhone phones). Texts have always gone through, but both my brother and I (he is also a RW customer) started having problems the evening of October 14, 2021 of texts apparently being sent, but never received. We have texted each other both last evening and today and no texts were received on either end when we have had no issue in the past). I also found out that there were other texts last evening I did not receive from other friends or businesses.

I don’t know if this is a problem that suddenly occurred with a recent update to the Google Messages app (my Moto G5 Plus says that the Messages version if 9.7.034)…but it seemed to start last evening.

The other thing I have noticed is that Messages seems to be optionally trying to turn on end-to-end encryption in some of my text threads and I have read on Google’s help pages that it tries to do this if the recipient can support that with their texting app. It also looks like that might be tied in to the “RCS chat feature”, but if so, that is odd as that setting is turned off in my Messages app. It was turned on in my brother’s Messages app on his phone, but I just called and asked him to turn it off and he did and that did not allow texts to go through from either of us.

Please help with this issue as texting on RW phones has always been reliable. My brother uses his for his business and missing texts is not only inconvenient for him, but also could be a financial impact.

Hi @marka.ddt4dz and welcome to the Community!

You are correct that end-to-end encryption is associated with RCS chat. RCS chat does not work reliably with Republic service. I understand you’re saying RCS chat is turned off on your phone, however, Google’s been known to turn it back on without asking after an update. Please forgive the obvious question but have you verified it’s still off?

If indeed it’s still off, and you haven’t already done so, please restart your phone and ask your brother to do the same. If messages between the two of you still fail, would you be willing to try an alternative app? Textra would be a good choice. Please note I’m not saying you or your brother should abandon Messages by Google. The suggestion of trying an alternative app is an attempt to narrow down the potential source of the problem.

Hi @rolandh . Thanks for responding.

Yes, I was searching the community here to see if there was information on this issue and read about RCS not working reliably with RW service (and I understand the reason given…as I work in IT and while I do not know the exact implementation of all of RW’s service, the fact that RCS is outside of their control is clear to me). I verified that Messages chat settings features for RCS are turned off on my phone. It was turned on on my brother’s RW phone, but he did turn it off…although he has not likely restarted the phone since doing so. I will ask him to do that.

I get your point on trying Textra as another data point for further debugging this problem. We will try that if the above does not solve the issue.

One other piece of data since I made the original post…I contacted another RW user friend of mine whose phone is running the same version of Android and Messages app and we are still able to text back and forth with no issue…although Messages is showing the “lock” icon showing the app things it is using encryption between us even though I have the RCS setting turned off.

2 Likes

@rolandh I just spoke with my brother. After rebooting his phone (which I also found out is an older Moto G model, maybe a G4 that is running Android 7), we verified that the RCS chat feature is still turned off in the Messages settings. Now he can receive texts, but when he sends a text it never arrives.

We also both installed Textra and tried that. Same thing. He can receive my text from Textra in his Textra app, but when he sends a reply to me, it never arrives.

This indicates to me that his phone is still attempting to use RCS. He can verify that by looking at the background color of the message bubble in Messages, is it dark blue or light blue? Dark blue indicates RCS while light blue indicates SMS/MMS. Assuming it is dark blue I would make sure that he deletes the thread with you and starts a new one to see if that’ll force messages to recheck your RCS status and move over to SMS.

@louisdi That makes some sense I will have my brother try that tonight.

Since then, however, another friend with an iPhone said she sent me a text this morning that I never received (while still having Textra as my default SMS app), but that was on an existing text thread (that used to work). So, I switched back to Messages as the default SMS app and verified that RCS was turned off in the settings and sent that friend a text and my Messages app said it sent it as SMS…and she received it immediately…but her reply to that text on the thread never arrived on my phone.

So, to eliminate the variable of an existing thread that was somehow “corrupted” by this RCS issue, I asked a co-worker with an iPhone to send me a text. We have never texted each other before so that would be a new fresh text thread with RCS turned off on my phone. His text never arrived. But if I text him directly, he receives it on his iPhone.

So…outbound SMS is working (on existing thread or new text thread) but inbound is not. This seems similar to what my brother is seeing now too. What is frustrating as we have not had any issues with texting for over year on RW phones…but it seems a recent update to Messages has triggered this problem…even when RCS is now turned off.

If you’re having an issue with someone with an iPhone, then that should rule RCS out as an issue (as they don’t support RCS) and so I think the next step is to open a ticket because Republic will have to look at their systems to see if they can figure out where these texts are going.

@louisdi Thank you for all the suggestions and help. It turns out clearing the app cache data for Messages “opened the flood gates” and all the missing incoming texts came in (timestamped tonight, but at least they arrived).

Being a software developer myself, this sounds like the recent Messages app update may have changed some data structures so that the cached data was unreadable or misinterpreted by the app, thus causing the issue. On principle, any app update should clear the cached data anyway. I had my brother do the same on his phone and it solved the issue.

Hi @marka.ddt4dz,

Thank you for posting the solution you found to this troubling issue. I have not seen others describing this issue and it’s perplexing to think it happened to both you and your brother, identically, yet we’re not seeing lots of tickets or Community questions about it.

We’ll keep your solution in mind, though, in case we do start seeing similar questions. Sometimes issues like this can sneak up on us as users, since it’s hard to know that we’ve not received a text message.

A lot of people would have simply gone on with their lives without bothering to update the Community once they found a solution. I’d like to thank you for taking the time to come back and let us know what solved the issue for you. If you and your brother would like Republic Wireless T-shirts, please send me a personal message by clicking my username and then clicking “message”. I’ll need to know your preferred sizes (S, M, L, XL, 2X, 3X) and shipping address(es). Please don’t send that information by public reply here, but only by clicking the “message” button so your address isn’t publicly visible all over the internet!

@southpaw Thank you. I was glad to share the solution since, as I mentioned, I am a software developer myself and know the importance of carefully debugging an issue, capturing steps to reproduce or solve the issue and providing that to customers. What took me a while to solve this (with helpful suggestions from others) is that I also did not find a widespread discussion of this issue with the latest Messages app update. While doing some more searching last night I did see a few mentions of this in the review comments on the app in the Google Play Store and Google support people suggested clearing the cache (as was also suggested earlier in this thread).

Thank you for the t-shirt offer! I will DM you as you suggest.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer