Moto G6 -Storage App will not open and my data is eaten up

I cannot get into my storage. For over a week now all it does is show the buffering ring and my data is getting sucked up and my battery doesn’t last as long. How can I fix it?

Hi & Welcome back!

  • A few more details would help the community help you
    • Which phone are you having problems with?
    • When you say you can’t get into your storage, what are you using to try to access the storage?
    • When you say your data is getting sucked up … what method are you using in detecting this?
    • On the battery problem, again knowing the phone you could probably be pointed directly to the app that is the culprit

I have a moto g6
I first go to “settings” then when I hit “storage” I get the circular buffering ring. And by the 6th of the month I was almost completely out of data. I extra G takes me through an entire month with plenty of data left over. I got an email stating that I only had 10% of my data left.

  • Possibly you could be confusing ‘storage’ and ‘Data’?
    • Storage is the amount of memory that the phone has, and how that is using being used.
    • Data is the cellular data you purchase from Republic and that is used when on cellular … this is what would drive the email from Republic
      • On my Moto X4, I find Data by going into Settings / Network & Internet / Data Usage … here is where I can see on a daily basis the amount of purchased data used, and broken down by app
        (as phones differ in where they hide things, you can go into Setting and use the Search function)

As a start, for the storage ‘problem’ you could clear both System and App storage: How to Clear Cache on Android – Republic Help

I am trying to go to my storage to see where my data is going but I can only get to the point of buffering, it will not let me in to see what I need to. That is the issue.

I did see where I can use the “search” to find my data but I am concerned that the perpetual buffering is drawing my data. I feel like something is searching causing me not to be able to enter my storage as usual. I’ve never in the past had this as an issue. And as I had mentioned earlier, this has been a constant for the past week and a half.

Usually if an approx time is known when the problem started, the cause can be traced to an App that updated
I would go into the Google Play Store on you phone and then the following
:menu: Menu top left/ My apps & games / Installed (Tab) and then Sort by Last updated. This should show the apps and date installed (or updated) and those that surround the date in question would be suspect.
You should also Clear all the Caches as previously mentioned

2 Likes

As mentioned above by jben. You don’t go to Storage to see your cellular data usage. You find which app is using cellular data while it has been running.

Hi @julieb.gukqaq - we check our cell data usage on our Moto G6’s using the RW app as described here –

We sometimes get the spinning circle when trying to view settings>storage and (if memory serves) a reboot seems to clear that for us.

Hope this helps!

1 Like

I tried what you recommended with the apps and now it works!!! Thank you!

1 Like

Thank you, I did try to reboot several times and that did not help.

1 Like

You mean the Clearing of the Caches?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Message an
Expert customer