Moto G7 no longer rings, all calls go straight to voice mail (recurring problem)

What phone do you have? Moto G7

What plan are you on? 1 Gig Data + Talk/Text

Does your plan include data, or just talk & text? 1 Gig data


Issue Description

Last summer my phone stopped ringing, I was assisted by Southpaw, Roland and the Member Community. I had been using an app for ringtones which may have contributed to the issue last year. Today I thought about changing my ringtone (why did I do that!!?) and once again my phone will no longer ring.

I have tried most of the suggestions provided last time (refreshing RW App, making sure volume is on/up, changing back to a resident RW ringtone). Every time I call my cell from my home phone, I see this notification “Republic Wireless Keeps Stopping” and the notification gives me 3 options: App info, Close App and Send Feedback. I’ve repeatedly tried to close the RW App but I cannot get it to quit. When I selected App info I got a message saying I wasn’t connected to WIFI which is odd because I default to WIFi. I was able to re-connect to WIFI. I also noticed Airplane Mode had been turned on (weird because I didn’t change that setting). I now have turned it off. Do Not Disturb is not on. I was thinking of disabling RW App but I’m concerned that isn’t the correct thing to do. I noticed in my ringtone list of options there are several downloaded options still listed from last year and I hope none of them are causing a problem even though a RW ringtone is once again selected. Also wondering if the MP3 file I downloaded for a ringtone is causing a problem. I did go to Files and deleted that and other non-RW ringtones.
Thank you all in advance for helping me with this issue!!

Hi @tracyp.qknums,

I’m not really sure where to start with this. Did you install an app in order to get the new ringtone?

Let’s try uninstalling and re-installing the Republic app, since you’re seeing a message indicating the Republic app has stopped.

Hi Southpaw
thanks for your help!
I did uninstall Republic app but on my Moto G7 it looked like I was just uninstalling updates and reinstalling them.
I have spam call setting set to allow anyone from any phone number to call me and yet when I try to call from my Voip/Ooma home phone the call does not go thru, nor is there a record of the call in ‘Recents’ at the bottom of the screen. I did get the popup about RW doing something (same as I noted in original post) but this time it allowed me to select a middle option, to stop RW from doing whatever that action was. Still I cannot get thru on my home phone (which is set to anonymous). I did get a call from another cell user this morning as well as from Google Voice. I am wondering if disabling Republic app is warranted altho I don’t know how to do it.
Hope that gives you enough info to keep us going to resolve this as you did last time!! thanks so much
I didn’t add a ringtone app but I did see a song on my phone as an MP3 so I downloaded it and it came up as a ringtone selection. Once I changed over to that, this problem happened. That file has been deleted but the song still appears in my ringtones, unselected.

We definitely do not want to disable the Republic app. Either uninstalling the app completely and reinstalling it, or uninstalling updates and re-installing updates works as a troubleshooting step.

There are a couple of different things people report as “not ringing.”
In one case, there is no audible ringtone but the phone lights up with a call screen, or, if you miss seeing that, there’s a “missed call” notification and the missed call appears in the “recents” list in the phone app.
That’s where we’d want to look at the ringtone you’re using, all the volume controls, and the possibility that a Bluetooth device may be connected or a speaker has failed.

In the second case, there is neither an audible nor a visible notice of a call - no ringtone, no lit-up call screen to answer, no “missed call” notifiction, and no listing in the “Recents” list. There’s only a voicemail notification if the caller leaves voicemail.

In this second case the ringtone is not a factor. Here, we’d want to look at things like whether you have any spam-call blocking enabled on your phone -either ours or a third-party tool, whether the contact is set to send calls to voicemail, (in this case, maybe something being set to send “anonymous” calls to voicemail) and whether it’s happening with lots of callers, or just one.

It sounds like the problem you’re describing is more of the second case, and that some calls are getting through. I’m concerned that some app is conflicting with the Republic app, though, and causing it to error out. Can you think of any apps you’ve recently installed or updated on your phone. I think in the past we found the “Hiya” app on your phone, which is a call blocking app. It’s not back, is it?

Hi
Hiya app is long gone and I haven’t added anything related to using the phone or privacy. This repeat issue started when I switched to a ringtone song (2 days ago). I have definitely learned my lesson to leave ringtones alone. After I made that ringtone decision, my WIFI was turned off and airplane mode was activated. My home phone is set to anonymous but what’s strange is it doesn’t register as a missed call at the bottom of my screen unless I leave a message. I just called my cell from my house, it didn’t ring or show me the answering options but I was able to leave a message from my home number. After leaving a VM, it showed up as a missed call (from me, my home phone number was listed). I listened to the message (after calling VM + password), it sounded good. I wish there was a hint to help us in these details. If needed I can list the apps I have on the phone, although because this issue started after I changed my ringtone, it doesn’t seem like an app is responsible.
I am able to get calls - my sister from the east coast called, the phone rang and the screen illuminated with the 3 choices. Same for my google voice number can get through too.

I called my cell from home number again and got the RW popup. It says Republic Wireless Keeps Stopping. 3 options are under that:
App Info
Close App
Send Feedback.
I had tried before to close app, should I try the other options?

No, the additional options there are not useful for this issue.

If you set your home phone to reveal the caller id (rather than calling anonymously) just long enough to call your Republic phone, does the same thing happen?

I will figure out how to do that and report back. thanks

Hi Southpaw
That worked!
I really prefer to have my home # blocked though so I hope this info helps us and I don’t have to leave that # unblocked. thanks for your help!!

Certainly, block it back! That was just for testing. It gives me a little more to go on and I can see if we can replicate the issue on a lab phone or maybe with some help from some of the @Ambassadors or @Experts.

thanks, I re-blocked it.

1 Like

After blocking it again, my home # doesn’t ring or connect to my cell. hope that’s helpful. My cell settings are to allow all calls.

I’m able to replicate @tracyp.qknums’ experience albeit not entirely consistently. Generally, I block “unknown” numbers. It’s a feature of more recent versions of Google’s Phone app.

For purposes of testing, I turned that feature off. With the feature off, calls from “unknown” numbers (both on and off-net) do not reach a Republic phone but rather are sent to voicemail as if blocked. That part is consistent. What is not consistent is the Republic app crashing. On two occasions, it’s crashed for me. On other occasions it has not.

With Google’s “unknown” call blocking engaged the call is shunted to voicemail and I note no crashing of the Republic app.

1 Like

I changed my cell settings to allow all calls/callers without any blocking. Prior to this weekend, I had locked down my cell and didn’t get many spam calls but now that I have discontinued this blocking, my home phone which is registered in my contacts won’t ring through.

thanks for checking into this Roland!

apologies for not adding this to last reply but my home phone (which does not indicate the phone number) not only won’t ring on my cell, it does not go to VM either.

Hi @tracyp.qknums,

The specific “unknown” or “private” number blocking feature I referenced is in Google’s Phone app rather than Republic’s app. If interested more is linked here:

The Google app you’re writing about is embedded in my phone already, correct? I just keep wondering why this has happened when I changed my ringtone to a non-RW song. Other weird setting changes occurred as well.

I really suspect the change was more likely related to an app update and the timing was coincidental with the ringtone.

Just to be very clear, the ringtones on the phone are not put there by Republic. They come as part of the Android build from the phone manufacturer. There’s nothing about the selection of a ringtone that impacts how our service works.

1 Like

thanks for explaining. I did however select a ringtone that I had downloaded as an MP3. It had been in my google drive for years.

Message an
Expert customer