Moto G7 no longer rings, all calls go straight to voice mail

unfortunately, I was sent straight to voicemail. I got an alert for the call/message a few seconds later.

I’ll get back in touch tomorrow, thank you for your persistence to try to figure out what’s happened to my phone. I greatly appreciate your help!!

You also mentioned seeing this earlier.
This means you have rules set in Do Not Disturb that will silence the phone, but allow certain exceptions. For example, when I go to sleep at night, I want my phone to be silent so I can sleep. I don’t want to hear it notify me every time someone posts in Community. I also don’t want to hear it if one of my co-workers messages me overnight. They can wait.
However, if one of my children or a specific, trusted friend calls or texts me, I do want to hear it, loud and clear. I also want my alarm to wake me in the morning, because it would be useless if muted. So those are my exceptions. The phone is silent unless one of those people tries to contact me.
You can tap “See all exceptions” to see what rules you have set up.

The little arrow where I marked yellow will open a screen that shows you your exceptions.

Tap the one I marked in red “Restrict notifications” and make sure “no visuals or sound from notifications” is not the one selected, please. When you do want “do not disturb” turned on, you’ll probably still want a visual clue that you’re getting a call.

You told us earlier that Do Not Disturb keeps turning on. Then when @SuperT showed you how to toggle it at the top of the phone screen, you said it was gray. Has it stayed gray? What indication did you have that it keeps turning on?

Tomorrow, I’d like to go through a few other settings with you, and if they also don’t make your phone start ringing, then I’d like to send some of your call traces to our technicians for review.

One other simple thing to try though:
Please refresh the Republic activation. This is like getting your phone and our servers to “shake hands” with one another and sync up correctly. You won’t lose any personal content on the phone.

Good night!

(We can work on getting the Republic app on your home screen tomorrow, too.)

thanks from the bottom of my heart!

I was able to get RW app on my screen last night. I also followed Refresh instructions, but still couldn’t get my phone to ring. Hope we can keep working on my issue, what’s the next step?

Good morning @tracyp.qknums.

First, let’s rule out any concern that Do Not Disturb is turning itself on. When you drag your finger down from the top of the screen, has the Do Not Disturb icon stayed gray? It’s not blue like mine, is it?

image

It is gray now, I think we were able to resolve that. thanks

Next, open the phone app and tap the three-dot menu :dots: and then Settings.
Tap Blocked numbers
Make sure “Unknown: Block calls from unidentified callers” is set to off and that you don’t see any numbers you’d want to reach you listed as being specifically blocked.


Then, again from the phone app, three dots :dots:, settings
tap Caller ID and Spam and just turn everything off to make sure that’s not a factor.

Then tap your volume up button on the side of the phone and tap the icon at the top of the slider until it shows a bell.
image

Once you’ve verified all of those settings, try calling from your home phone. Let me know the results once you’ve done so, and I’d like to try calling you, myself, as well. (Don’t share your phone number by reply. I have it.)

Those were excellent directions, thank you!
1- Blocked numbers: was and is presently set to off as in your example.
2- Caller ID & Spam: is/was set to off
Volume is all the way at the top now.
3- I called myself from my home/Ooma phone, did get a slight bit of ring tone but then was sent to voicemail.
Ready for your call, thank you!

Good morning @tracyp.qknums

Would you please try booting your phone into safe mode and then trying calling your phone? (Safe mode should not bother the Republic app on the G7 ).
Here are instructions to get to safe mode:

Procedure

  1. Press and hold the Power button for 2-3 seconds until the Power off pop-up message appears
  2. Press and hold the on-screen Power off pop-up message until you see Reboot to safe mode
  • Note: If you are running Android 8.0 Oreo or higher on a Nexus, Google, or Motorola phone, this will automatically reboot the phone into Safe Mode without showing the pop-up
  1. Tap OK when the Reboot to safe mode pop-up appears
  2. Your phone will reboot and Safe Mode will appear in the bottom-left corner
  3. Try using or testing the issue you were experiencing while in Safe Mode

(This is in-case your test above with @southpaw fails) :wink:

To follow up on our calling test -
My call did reach your phone, but your call from your home phone to my RW phone went straight to voicemail, even though I don’t have any kind of blocking set.

@SuperT’s suggestion of testing in Safe Mode wouldn’t hurt.

I’m going to open a ticket on your behalf and it’s going to take me a while to get a bunch of notes into it about what we’ve tried, what’s happening, and some details from the call traces. Then I’ll send it for technical assistance. I don’t think this is something that is happening on the phone itself that a setting tweak will solve. I think this is going to need to be fixed on our end.

Your persistence is reassuring, thank you so very much.
I’ll wait to hear from you!
I will try @SuperT’s suggestion too.
t

Hi @tracyp.qknums,

I have one more request for you, when you’re on WiFi. Would you please open the phone app as if you were going to make a call, and dial * # * # 5647 # * # *.
It’s going to seem very similar to refreshing the Republic activation, that I asked you to do last night, but this dialer sequence is different by one digit and uploads your phone’s error logs to our servers for our technicians to review.
You’ll have to tap to “allow” the phone to send the logs.

Thank you.

Done, hope it bears some info. thanks

1 Like

Hi Southpaw, wondering if there’s any good news in trying to figure out my problem? thanks

Hi @tracyp.qknums,

I wrote everything up and sent it to the team for technical review late yesterday. I won’t let you be forgotten!

1 Like

Thanks so much!

1 Like
Message an
Expert customer