Moto G7 no sound alert for text

What phone do you have?
G7
What plan are you on?

Does your plan include data, or just talk & text?
No data


Issue Description

Phone not giving alert sound for incoming text. Calls working fine. Have turned up sound in everything in settings that I can find. Doesn’t seem to be a sound option within text settings except for outgoing sounds. Have everything in notifications on. Tried safe mode. Read other people’s posts. Occasionally will give sound, perhaps when conversation is open? But not the sound I chose.

Hi @amyb.xba25c and welcome back to the Member Community. Sounds like you have checked quite a few things. Here are a few other settings you might want to check. We have two Moto G6’s and here’s the steps. Think the G7 settings are the same :thinking:

  1. Open Messages App
  2. Tap three dots upper right
  3. Tap Settings
  4. Tap Notifications and make sure Show notifications toggle is on
  5. Scroll down to Other section>Tap Default
  6. Next screen - tap Behavior>Behavior Windows pops up>Make sure “Make Sound and pop on screen” radio button is on
  7. Go back one screen (has Behavior and Advanced) - (Pop up window closes)
  8. Tap Advanced
  9. Tap Sound - make sure message sound is not set to None. This is also the default messages sound.

All easy checks! Come back if these suggestions do not help :smiley:

3 Likes

Thank you! Under behavior it was on no sound. And I had never found that setting for choosing the text sound. Thank you!

3 Likes

You’re welcome. Glad you got it working!

Message an
Expert customer