Moto G7 WiFi connection

Just got my Moto g 7. I have the small “arc” at the top-but it is hollow-so it would seem that I am not connected to WiFi. When I press the WiFI it says I am connected. So i’m not sure how to tell if I am on WiFi or not so I feel like I am getting two differing messages.

The WiFi can be ‘connected’ but not of the quality to fully support Republic Wireless phone calling and.or messaging.
Do a one finger swipe down and then look at the Republic Wireless ‘Notification’, verbiage and color of the arc will help narrow the problem down and will let you know what restrictions are. Check the Help Doc for full details

  • Please post back what you find and the community can better respond

Thanks Jben. There is a hollow blue arc. the message on pull down states "Calls over cell, messages and data over WiFi. This is my first time at work with my new phone, connecting to the WiFi here. My last RW moto had no problems. It will very briefly show a filled in arc, but then goes hollow again. From the help document-the following is true:

  1. On WiFi: Calls over cell, messages and data over WiFi
  • This status may show full arc however if something is blocking SSID (firewall, ex.) then cell data may still be used, or some sites may be inaccessible through the WiFi network.
  • Empty blue arc

But, I just don’t know what to do about it…

Ok, thanks for the complete answer, which raises additional questions :frowning:

  • What was the previous phone?
  • Could you Receive & Send a text, then check the log to see if they actually were received/sent via your WiFi?

Previous phone was Moto x 2

How/where do I check log for the text?

Ok, checked the texts, looks like they were indeed over WiFi. But (dumb question) there is no “key” under View Calls and Messages as to which symbol is Cell and Which symbol is WiFi. I am assuming cell is the perpendicular lines that get taller going to the right, and that WiFi is the 3 arched triangular lines.

Sim type is GSM.-not sure what that means or if it matters.

Another question, is on my old phone the arc was always present at the top of phone, filled or hollow. on this phone it only appears once and a while, both filled and hollow. Not sure if that is normal.

Trying to to the portquiz(s) but they are not loading on my phone.

(thanks for your support)

[quote=“kristib.jakovl, post:7, topic:27533”]

  • Define of WiFi Cell icons … Your assumption is correct

  • Sim type is GSM., it means that your carrier is now T-Mobile, so you are on different carrier that before (so you may find better worse cell coverage, if this ever becomes a problem for you then check out How to Request a 3.0 CDMA SIM Card – Republic Help

  • old phone the arc was always present at the top of phone, filled or hollow. on this phone it only appears once and a while, both filled and hollow. Not sure if that is normal.

    • That would be ab Normal … lets come back to this later
  • Trying to to the portquiz(s) but they are not loading on my phone.

Tired all 5 ports on phone listed in the link you provided. First they would all stall out to an error page. Then turned my phone off, tried again, ports go to a google list of pages…no “results” if i click on the tip listing it just stalls out.

I am at my work, a large company…I have no router to reset, etc…so not sure what to do next. I am on a WYSE dell at work, so I don’t even have an actual computer tower to restart…but then again I don’t think that has anything to do with it.

On the SIM Type, I provided you some bum dope, fortunately one of my fellow Ambassadors noticed it … it is coming in the future but not available now

Republic currently has no CDMA SIM for the G7 series. For now, they’re GSM only with Republic despite hardware compatibility with CDMA networks

On the WiFi connectivity, I would suggest the following:

  • Test connectivity/calling at a known open WiFi like McD or Starbucks, then assuming that it works ok there you would need to work with your IT folks
  • You may want to show your IT buddy the Required Ports & Protocol info, it was originally developed with users, IT personnel (University) and Republic Staff
  • I would also Open a Ticket and provide them with reference to this discussion and the results you got from How to Test If WiFi Ports Are Blocked – Republic Help and see what they suggest

I have a similar problem at my office. Our office Wi-Fi blocks the ports necessary to handle RW calling, while giving adequate performance with text and data. There’s nothing I can do about it. Fortunately the GSM signal is strong so it’s not an inconvenience for me.

You mentioned that your previous RW phone worked on Wi-Fi at the same location. It may be a long shot, but if you office has 2 Wi-Fi networks–older 2.4GHz and a newer 5GHz–the two might be set up differently. Your older phone might have been on the older network. If that’s the case, try connecting with the other Wi-Fi network and hope that they haven’t blocked those ports.

2 Likes
Message an
Expert customer