Moto GS5 plus won't connect to LTE

What phone do you have? brand new moto GS5 plus

What plan are you on? 1 gig data


I just pulled my new phone out of the box today. (I did not purchase from Republic) Previously, I had a Moto G4. I removed the Sim card from the old phone, removed the excess plastic so it fit in the GS5, and put it in the new phone. My phone is only connecting to the 3g network. My husband has not switched to his new phone yet, and when we are right next to each other, his G4 is connecting to LTE, while mine is still reading 3G. Did I do something wrong setting up the new phone? LTE is my preferred network type in my settings. Any advice is welcome!

It’s possible the SIM was of the type that can’t be moved. Let’s start by checking that. Can you please take a look at the SIM and check the word “Republic” is it in all black/gray or is the public part in “Green”?

2 Likes

Public is in green.

Ok, so that SIM should move without issue. Sounds like an incomplete activation.

Please try the following steps to resolve this issue:

  1. Reboot the phone in an area that has a strong cell signal. (Some people have simply needed to step outside and reboot.) If this fixes it, stop.

  2. Please ensure the data is turned on in Android Settings. Settings > Data Usage > Cellular Data (some phones may say Mobile Data). If this fixes it, stop.

  3. This one is more complicated. This step will clear out any saved connections for Wi-Fi and Bluetooth that you may have already made. We’re going to reset the network settings.
    Go to Settings > Backup and Reset > Network settings reset
    Read the warning, tap “Reset settings.” You will be warned a second time. Tap “Reset settings” to confirm. The process will usually take 5-10 seconds and the cellular signal bars icon will go away for a moment. Once the cell signal bars icon returns, you should reboot the phone.

2 Likes

I do not have a network reset option in the reset and backup menu.

Does anyone know how I can reset my network settings?

@louisdi’s guidance is mostly correct. The path he supplied for a network settings reset is slightly off for your G5+. Please try Settings -> More -> Network settings reset.

Thanks for the help, but it didn’t work. My husband sitting next to me with the same type of phone is connected to 3G network, I’m connected to an H. I had LTE at this location with my old phone.

Hi @lisaajb,

With the phone on Wi-Fi, please try to refresh the Republic activation.

“Wi-Fo”? :stuck_out_tongue_closed_eyes:

:rofl: :rofl: :rofl:

Move along, nothing to see here. :grin:

2 Likes

Thanks. I refreshed the republic activation. It connected to 3G, but still not getting any LTE. I went ahead and did a factory reset and did not restore from my old account, but still stuck on 3G.
I’m not sure if this is related, but the republic app keeps telling me to enable roaming data, but roaming data is already turned on.

Can you both try this on your phones:

  1. Launch the dialer as if you were going to make a call.
  2. Tap the numeric keypad icon.
  3. Dial *#*#786#*#*

What do the phones do? Does the screen just clear or do you get a SprintDM screen on each phone?

##786## does absolutely nothing.

Sorry, the forum software got me. Corrected the sequence above.

1 Like

Ah, but ##786## clears the screen.

Got me too

Clears the screen on both phones?

Correct

I’m out of ideas. Wish I could be of more assistance. I think we’re down to some weirdness with the SIM. The reason I asked you to perform that test was I was hoping that we’d find that you and your husband were on two different underlying carriers, accounting for the difference. Instead, we proved that theory wrong.

Message an
Expert customer