Moto X 1st Gen Stuck on Boot Screen

incomplete
#1

What phone do you have?
What plan are you on?
Does your plan include data, or just talk & text?


Issue Description

My moto x is stuck booting at the boot screen.I had just loaded Alexa from play store and the phone rebooted itself. Now it is stuck. Help.

1 Like
#2

Hi @licomic
Hold that power button for 2 minutes and see if it reboots the phone normally

5 Likes
#3

@bocephous tried holding power button down for 2 + minutes several times with no luck. I also tried clearing/reformatting cache but that seems to hang when it is reformating partition. Should I try a hard factory reset?

#4

I would wait as the factory reset is a last resort. I suggest making a support ticket out and in the meantime someone may chime in with info needed to help you further than I could.

#5

Hi @licomic

Have you tried going to the PlayStore and uninstalling the Alexa app on your X1 from a PC or other device?. I would give that a shot before a FDR (Factory Data Reset).

3 Likes
#6

My Moto X never recovered. I was able to stay on my 1.0 plan by buying a new old Moto E 2nd Gen. Not as good as the X but servicable. I’m happy.

2 Likes
closed #7

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Message an
Expert customer