Moto X 2nd gen no WIFI

Moto X 2nd gen no WIFI. Wife’s is connecting. When I go to RW wifi setting it does not show and Saved Wifi saved networks. Rebooted phone and nothing changed. How do I fix this. $10 refund plan

I’m sorry to be the bearer of bad news, but when the networks show nothing at all, that is nearly always a hardware failure of the wifi radio in the device. I would try booting in to Safe Mode to see if that makes any difference, and if it doesn’t that will largely be confirmation that this is a hardware failure.

I rest the password and network and it still does not connect

Wife called from her phone and mine rang

Your phone ringing wouldn’t have anything to do with the wifi radio, as the call would come in over cellular. If you see no networks in safe mode, then I’m afraid my initial diagnosis is likely correct.

1 Like
  • Does the WiFi still work at other locations? (McD’s/Starbucks)
  • Have you rebooting your Router?
  • Perhaps the :motohelp: Moto Help (found in the :appsicon:) and then the Fix Tab would provide a test?

The safe mode you posted does not work for motox 2nd. Can you give more specific directions. I saw on line to reboot and hold the power button down until you see the re-boot but that does not work either

to enter safe mode hold power button until a popup asking to shut down come on the screen then hold that popup until the phone reboots (and it will boot to safe mode) to exit safe mode is a simple power down and power up

1 Like

I held the power button down through 3 reboots and now it says Android is starting and optimizing 45 apps. Went through all that and still not connecting to WIFI
I am sure it is the phone like louisdi says.

I am looking at this phone: Moto G⁶ Play Not looking to spend a lot because I am retired and only use it to keep in contact with wife when I run errands.

Hi @richardh.o3elaj,

The trick to getting into Safe Mode is not to hold the power button down. Holding the power button down is meant to reboot the phone, as you’ve seen.

  • When the phone is on, and awake, press the power button just until a “power off” message appears on the screen. On my X2 it takes about one second for that message to appear.
  • Release the power button
  • Touch and hold the “power off” message on the screen.
  • Another message will appear with the Safe Mode option. Tap “ok”.
2 Likes

Thank you southpaw. It rebooted in safe mode and restarted, still no wifi.
Going to start a new thread for new phone suggestions.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer