Moto X Gen 2 - Activation Loop

activation
#1

I used to have a RW Moto X1. My wife gave me her RW Moto X2 phone, so I set-up the phone and migrated my information to the new X2 phone. The problem is my phone number isn’t transferred. I get a message saying that my phone hasn’t been activated yet, but when I try to activate, it goes into an endless loop. Specifically, I get a green message that says “please activate your phone so you can access this app.” When I tap “activate now” it takes me to the welcome page which says “once the startup process is complete you’ll be asked to restart your phone in order to complete activation.” I tap ok, and I am back to the original green “Activate”message. It just keeps looping. I’ve tried turning phone off and then back on. I tried factory resetting and remigrating, but nothing has worked. I’d appreciate any help. Thank you.

#2

Hello @katie, welcome to the community

the next step I would take would be to uninstall updates to the Republic apps (both Republic Wireless app and the Republic Telephony app) (edit this is done though the Google Play Store app) then reboot the phone and reinstall the updates to both apps and then try and activate again (please note activation requires WiFi data connection)

It should be allowing you top login to your account and select a current line.

another thing to try is to see if you can activate in safe mode (press power button until the power off popup appears then press and hold the popup until the option to boot in safe mode appears)

if this does not correct the issue I would open a ticket

3 Likes
#3

Please see this announcement

1 Like
#4

Thanks so much! I ended up opening a ticket, and after many attempts, we were finally able to get it to work. Thanks again!

1 Like
closed #6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer