Moto x pure can't receive sms; sees them as mms

I just got a Moto X pure on Republic 3.0

I live in an area (Bozeman, MT) with no data coverage; I assumed this is not an issue because I use the $15 talk/text/wifi plan (I do grumble that it is 50% more than the Republic 1.0 plan I enjoyed until my old 1st gen Moto G became essentially unusable).

My wife has an iPhone on Verizon (the only carrier with data coverage around here–seriously, check the map). She sends me texts, and when I’m not on wifi, Messenger (I made this my default text app per Republic instructions) says the texts are MMS and need to be downloaded, which can’t be done over cell (even if I paid for cell data, because there is no cell data coverage here).

When I get back to wifi and download, I see the message does not contain anything but plain text and therefore in my eyes should be SMS, not MMS.

What can I do to receive texts from my wife while on cell service (this should be included in my plan)? If I can’t figure this out, I’ll have to sell my Republic Handset and become an over-paying Verizon dope. Republic 1.0 always worked well for me; now I may just be screwed.

@jeffk.4n4mgp

Are you using this app? Messenger - Android Apps on Google Play Try deleting it and redownloading it.

*** ~~ßocephous™***

I’m using it.

I guess I’ll uninstall/reinstall, but that sounds like advice from the Comic Book Guy who is my IT guy at work…

@jeffk.4n4mgp

As I understand it, your phone needs a little bit of cellular data to set up phone calls and texting. Unfortunately, your new phone is on TMobile’s network and not Sprint’s.

You can open a support ticket to see if they can do anything for you. Right now your options are:

  1. Continue using the phone and hope TMobile updates their network soon or Republic makes Sprint available for BYOD.

  2. The phone in unlocked, so see if you can use the phone on Verizon and hope that Republic makes Sprint available for BYOD.

  3. Sell the phone on Swappa or Ebay and buy a used Republic Moto G3 which will get you back to Sprint’s network. Buying and Selling Used Republic Wireless Phones

Republic Help

Troubleshooting Texting Issues

**No or poor data connectivity
**

Note: For Republic Wireless 3.0 Phones (Google Pixel and Pixel XL, Huawei Ascend 5W,** **Moto X Pure Edition, Moto G4, Moto G4 PLUS, Nexus 5X, Nexus 6P, Samsung Galaxy J3, S6, S7, and S7 edge), our GSM provider requires mobile data to be enabled in order for all messaging, including SMS, to be sent from the phone. See Check Network Settings for instructions on making sure mobile data is enabled.

I have this exact same story. Been happy with republic for 3 years. Had to update my phone as my original Moto g was unusable. Bought a Moto x pure. I cannot receive text messages unless I am on wifi! This has already caused huge issues for me, as sometimes texts are very important to receive and affect our plans/decision making. I have missed opportunities and had troubles due to missed messages. My phone will alert me I have an MMS message to download, but I can’t download it over cel. When I get to wifi and I am able to download it, it is not an MMS message at all, rather an SMS message. I have gone through all the network settings as suggested and made sure all is enabled. This is a deal breaker for me. If I can’t get this fixed I’m going to have to go back to Verizon after three years of glorious freedom.

I’ve had the same issue on my Moto X Pure. I thought I found a fix by clearing data on the Messenger app. That seemed to fix it for a while, but soon it was back to its old ways. It only seems to happen when I’m “roaming” (although the phone doesn’t indicate I’m roaming) on an AT&T tower. Once I’m back in native T-Mobile territory, everything seems to work fine. I have no idea why clearing data fixed it temporarily. Doesn’t seem to make sense, but it did.

The only other thing I can try is the “nuclear option” and delete all my text messages. That was suggested as a fix. I imported the ones from my old first gen Moto X.

Like the original poster, the messages I receive are showing up as MMS even though they aren’t. Mercifully, texts are not mission-critical for me, but it’s still annoying. Never had this problem on my old phone with the 2.0 plan. FWIW I have data and roaming data on even though I’m on the no-data plan.

OK, I decided to try the nuclear option. I used SMS Backup and Restore to backup my messages to my Google Drive. Then I used it to nuke all of my texts. I also went into Messenger’s app settings and cleared data. After rebooting, texting seems to be working fine again. We’ll see how long it lasts.

I had also tried using the ## code to reset the RW app settings. Didn’t help.

Well, that didn’t take long. It worked for the first few messages, now it doesn’t again. I’m going to open up a ticket.

I opened a ticket. Unfortunately nothing helped other than clearing data on Messenger which will make it work for roughly ten minutes before stopping again. I almost wonder if it’s a Messenger issue but I can’t diagnose it any further. The only “solution” at this point for me is waiting for the CDMA BYOP to be ready.

This issue JUST AROSE on my Moto G4. While on WiFi SMS messages arrive as MMS, requiring manual download (an extra step ). Even though there is NO MEDIA ATTACHED!!
This phone connects to 1-4 TMobile towers while I’m on WiFi. Issue began about a month ago. WHAT’S UP WITH THIS RW???

Sounds like your Internet over cell is not working on the new phones ALL MMS and SMS come over data only. Make sure you have Cellular data and Roaming turned on. If they are, connect over WiFi and dial *#*#8647#*#* no need to hit send on your G4.

Then restart your phone. The key is if no data at all you will not be able to send or receive text messages on 3.0 phones.

1 Like
Message an
Expert customer