Moto X Pure - Missing calls and texts until reboot (title updated)

today i ran a diagnostic and it says a test failed to read the MCC/MNC of the cell operator. please check that you have a republic SIM inserted.

i googled the issue and found another post on it - they had the guy do a ##8647## - his issue was resolved - i did the same thing but my issue has not gone away. the error still shows when i run the diagnostic again.

i have a Moro X Pure

i am on the talk and text plan.

Are you having service issues?

3 Likes

i have been having intermittent issues with not receiving phone calls and text messages and having to frequently power off and back on my phone in order to find out that i missed calls and texts.

Any response?

Hi @cvanciger,

I’m sorry your response went unnoticed! I’ve changed the title of your topic to encourage others to chime in. Most of our Community members don’t have experience with the particular diagnostic you’re seeing, but they may be able to troubleshoot the actual issue you are experiencing.

Have you been able to determine whether you are missing calls and texts primarily on WiFi, or cell, or does it happen on both?

How strong is cellular coverage in your area?

it happens on both but i am mainly at home where i get zero cell coverage, so i am totally dependent upon my wifi to do anything. the problem is that the republic phone/service continually drops off the phone and i get messages such as emergency calls only, no voice calls authorized, no network detected. in my view there should be no reason why the republic service on the phone should ever drop unless my wifi drops. i have been missing important texts and calls from doctors and my kids teachers and i am not aware of it until i reboot the phone. there is never any real indication that i am not receiving services until after that reboot, as even when i see the republic green bar, which should indicate a reconnection to the service, i don’t get those voicemails or texts

  • If you have ‘zero cell coverage’ at home it might be worth it to try the following
    • Place phone in Airplane Mode then turn the WiFi back on
  • Ensure you have removed as many of the obstacles from your WiFi as you can
  • Does this occur after a period of time when the phone is idle? (screen off and not moving) … this might be a indication of Doze (where the Android code puts the WiFi to sleep to conserve battery)
1 Like

Hi @cvanciger,
Have you had any luck with the problem or have any additional feedback you could share with the community?

i looked up doze mode and it says battery optimization is not available for:
carrier provisioning service
carrier services
download manager
google play services
motorola update services
republic wireless

the phone is not always idle for long periods of time, the republic wireless app just drops or goes to a restricted service mode where it says all voice calls are blocked, sometimes while still connected to wifi. there seems to be no real reason for it.

  • Again, sorry for the long delay for any responses
    • On doze mode optimization, it is my opinion that the setting of this does not have any discernible effect on the connectivity. The delay before our phones going into Doze Mode and shutting down the WiFi in/out varies from about 3-60 minutes and, and this is based on all the testing that I have been able to conduct.
    • The only way that I can say for sure to rule out doze is to have the phone on a charger.
  • All I can offer is to check that your WiFi is up to snuff, as ISP’s are being impacted by the max usage demands we are all placing on our devices
Message an
Expert customer