Moto X Wifi Only Call/Text Not Working

Been with Republic since the initial rollout of Moto X. I’m in Alaska now and just re-activated a Moto X 1st gen (or 2nd gen) on the $5 wifi only plan. Neither calls or texts are working even though I’m connected to my home wifi. Call attempts give me the “cellular network not available” message. I don’t expect to use cell towers hence the reason for wifi only. Any ideas on how to remedy this situation.

Try this:

  1. Tap the Phone icon.
  2. Tap the Dialer icon.
  3. Dial ##8647##
  4. The dialer will disappear. If an activation screen appears, wait for the process to finish, then tap GREAT THANKS!.
  5. The Republic Wireless notification icon may disappear briefly then reappear. If the icon does not reappear after one minute, Restart your phone.

That didn’t work. Any other ideas?

What does the Republic Arc look like? When you pull down the notification shade, what does the status for the Republic app say? Finally, have you tried putting the phone in airplane mode and manually reenabling wifi and then making the call?

The short of it is I’ve now transferred the plan to an old Moto G/E phone and it’s working fine. As I recall we had started having this problem with the Moto X when the updated android system was pushed out. I spent way too much time with RW tech support trying all the things you’ve mentioned and nothing worked. That was frustrating because I prefer the Moto X over the G and E. But at this point it meets my need of having an active wifi phone.

Message an
Expert customer