Moto X2 how to uninstall updates to the RW app

moto x2 how to uninstall RW app Please be as specific as possible

There is no Republic compatible Moto G2. Assuming you mean the Moto G1 or G3, or the X1, X2, E1 or E2 it is neither possible to remove the Republic App nor is it possible to use those phones with any carrier other than Republic.

2 Likes

Sorry Motox 2

@louisdi’s answer still applies. The best one can do is disable the Republic app and doing so won’t make it possible to use the phone on a network other than Republic’s Republic’s word is here: FAQ: Are Republic Wireless Phones Locked or Unlocked? – Republic Help. Legacy phones are also referred to as 1.0/2.0 phones.

I cannot set up voice mail and support told me to do this:
In attempt to get your voicemail set up, please follow the troubleshooting steps in Unable to Set Up a Voicemail Password.
I cannot find where to do this

Ah, thanks for the additional context! What you can do is uninstall, then reinstall the Republic app’s updates.

Please note, uninstalling then reinstalling your Republic app’s updates will delete all data in the app. You will no longer be able to see your past cellular usage history. If you want that preserved, please take screenshots. Any configurations you have set, for example, WiFi network auto-joining, saved captive portal authentications and handover management (whitelisting) will need to be reconfigured.

With that said, here are the steps to do so:

  1. From your home screen, tap on the Play Store app.
  2. Tap the menu stack (three lines to the left of the words Google play).
  3. Tap My apps and games.
  4. Scroll until you see the Republic app then tap it.
  5. Tap Uninstall and confirm.
  6. Reboot your device. This is the crucial step.
  7. Repeat the first four steps.
  8. Tap Update, then Accept.
1 Like

The problem is when I tap the Republic Wireless app there is NO Uninstall. It is the page that has that says Your Phone Info

The steps I provided don’t ask that you open the Republic app itself. They start with the Play Store app.

1 Like

OK I misunderstood but it is asking do I want to uninstall all apps. That cannot be right

What’s asking if you want to uninstall all apps? Do you have Google’s Play Store app open?

yes I do

It seems I missed a step, however, I don’t see any option to uninstall all apps. Please try again as follows:

  1. From your home screen, tap on the Play Store :playstore: app.
  2. Tap the menu stack (three lines to the left of the words Google play).
  3. Tap My apps and games.
  4. Tap Installed.
  5. Scroll until you see the Republic Wireless app, then tap it.
  6. Tap Uninstall (the message I see asks if I want to uninstall all updates to this Android system app not all apps you do).
  7. Tap OK
  8. Reboot your device. This is the crucial step.
  9. Repeat the first four steps.
  10. Tap Update, then Accept.
1 Like

Ok I have in uninstalled and re-installed and it fixed the problem one time. I cannot set up a password for voicemail or a greeting; it just spins and spins. After what I did what you told me to do, my wife called me and it rang. She hung up and called me back and got “the republic wireless customer is not available”. We are sitting 1’ apart and 1’ from wifi. I have worked with support since Friday. On my own I have did a factory reset 3 times, tried everything support has suggested and nothing has worked. She can send me text just fine but she or no one else can call me.

Hi @richardh.o3elaj,

You’ve mentioned a couple of times now that you’re working with support on this. While we would love to help, too many cooks in the kitchen are more likely to hinder rather than help the process. It would be best if you updated your ticket with the fact that their suggestions have, so far, not worked then wait for further guidance.

1 Like

One last thing to try. Resetting your Republic credentials. Open the dialer, enter *#*#8647#*#* the screen should clear. When it does, restart the phone. Does that change anything?

Nope, nothing happened. ##8647##

louisdi
Can you see my tickets?

No one but Republic employees and the actual user that opened the Ticked can see it. @louisdi is like all of the contributors on the forum, that do not have a :rw_3: over their picture are uses/members just like you.

Hi @richardh.o3elaj,

The sequence to dial is*#*#8647#*#*

southpaw
Nothing happens when I dial that either

Message an
Expert customer