Moto X4 Compatible

Yes, this would be compatible. Matches my X4 that is active and is listed here by Republic Motorola moto x⁴ – Republic Wireless


I’ve had the MotoX4. It just died with it looping and I’m unable to do a factory reset so I’m considering replacing it with the same or going with a newer model. I’m having a hard time deciding. I do like the phone, but they seem pricey online for an old model that is no longer being made. So I’m wondering about that too.

1 Like

Hi @sharig, :slight_smile:

Have you tried a factory reset via this method:

If you are still not able to reset the phone and have a Windows PC and a USB data cable… there is a software tool made to fix the kind of problem your moto x4 is experiencing.

Please look over this guide to the Lenovo Rescue and Smart Assistant tool:


Oh thank you so much. My phone won’t power off, but I’ll try this. It would be so wonderful if it works!!!

do you like the phone?, I realize its 3-4 years old but, I use a phone for it’s basic purpose.

thanks for your rep[y

Yes, it has served me well, it has been primarily used for continuous testing of my efforts to overcome Androids Doze problem: Managing Doze Mode - (While on WiFi) calls arrive via cell | calls go to voicemail | calls are missed
I still prefer Motorolas, but I guess I’m fast becoming old school :frowning:

1 Like

I’m highly confident we can get your phone back to working order. :slight_smile:

I understand that if you try turning off the phone by holding in the power button it will restart.
Try this… Hold the power button down and the second the screen goes black press and hold the Volume down button as well (You will still be holding the power button).
That should bring up the little “dead android” screen. From there you can follow the factory reset instructions I posted starting at step 3.

I do like it. I tend to keep my phones for a very long time so I can’t compare it to the newer technology. My previous phone was a MotoX2 I think it was. The battery died so I had to get a new one. I still have it and may reactivate it so I can get my voicemail. I wouldn’t even be considering a new phone if mine didn’t have that problem of looping. So I need to try this Lenovo Rescue and Assistant.

I like your confidence. Here’s what happened when I went to reset it. I got the “dead android” screen. I got to the START and scrolled down with the down volume button until RECOVERY appeared, selected it and never got the COMMAND option, it just went right into looping with ANDROID ONE flashing on and black screen, my phone is still doing that. Do you still think this rescue tool will work. I haven’t tried it yet.

Getting to the “wipe data/factory reset” is a little tricky but… ya… I have confidence in you! :slight_smile:

Go back to where you have “Recovery” and when that is showing… press the “power button”.
The phone should restart and again have a “dead Android” on the screen. It should look something like this:


Can you get that far?

1 Like

In the event we can’t use the internal reset of the phone, yes I think the tool will work.

1 Like

When I pressed the power button it just kept looping. I haven’t tried the tool yet. I couldn’t get the No Command option.

Okay then, it’s time to use software against software! :grinning:

Please install the tool and have the USB data cable ready. Then follow the instructions from the guide I posted for you earlier.

If you run into trouble give a shout-out here. :slight_smile:

This is what the screen will look like when you select your phone model:

I’m having a hard time finding where to download the software. I went to the Lenovo Forums site. Is it right in front of my eyes? I see the instructions on how to use it, but how do I get it?

Go to this page:

Rescue and Smart Assistant (LMSA) - Lenovo Support US

And click where I circled in red:

1 Like

Hi Super T,

I couldn’t get the COMMAND option, so I am now at the RESCUE part. I don’t know my model # and don’t see it in my RW account or on the phone. Any ideas? I can see the serial #, but the first step is model #.

Moto X4 is the XT1900-1

thank you

unable to read incompatible firmware or some message like that

unable to read the match the appropriate firmware. Some key information cannot be be read from the device.

So it sounds like I need a new phone. Would you agree?

Message an
Expert customer