Moto x4 no longer auto connecting to wifi


#22

Yes…nothing changed there and no issues other than mine.


#23

Was one of the first things I tried…have reset twice since the initial reset…no luck


#24

Ok…both my older phones are working with work wifi…current and older tablet are working with work wifi…wife’s E5 working with my work wifi…still no luck on the X4. IT has confirmed that nothing has changed in the past 10 days and the phone connected just fine prior to me resetting.
Since our building is fairly large and my office is in the center on the lower level, I get zero cell signal…if I don’t have a working wifi, I have no access to client calls and texts. If I can’t find a Republic solution, I may hafta go back to Verizon, as much as I hate them…wife can stay with RW. :unamused:


#25

My guess is that a factory reset will likely remedy the situation. Of course, that can be a bit disruptive but definitely worth a shot.


#26

I don’t see where you have been asked to boot up in Safe Mode?
There is always the possibility a 3rd party app that was updated about the same time is the culprit?


#27

Why would a third party app misbehave on just one network?


#28

Hi @bwram1,

Is this the only hidden SSID you’ve tried to connect to?

On your screenshots above, under “Advanced Options,” I see your options for Metered and Proxy. Do you have “Hidden network” set to “Yes”?


#29

Other phones that @bwram1 has tested work … so I am assuming that there is something different about his X4 … the easy way to narrow these difference down is by using Safe Mode. A factory reset, unless a user does not choose a restore cleans it all up and restores it, with all the 3rd party apps intact.


#30

On the Motorola troubleshooting link, it is suggesting to turn off mobile data, then turn on WiFi or Wi-Fi and Bluetooth.
"If other devices are able to connect:

  1. Turn Mobile data off and turn Wi-Fi on

  2. Try to turn on both Wi-Fi and Bluetooth"

(https://mobilesupport.lenovo.com/us/en/chat).
This https://support.motorola.com/us/en/documents/MG5084 is the link for Motorola troubleshooting.


#31

One thing I have noticed is the security…on other devices I see WPA/WPA2/FT PSK…on the X4, there is no FT…that is the only difference I am seeing.


#32

I have tried yes and no under hidden…have tried about every combination there is under advanced


#33

From a bit of digging, I can find ‘FT’ is 802.11r and FT is Fast Transition, normally an Enterprise function that enables AP to AP roaming.

  • Per a user response Moto support forum it appears that it is supported in Oreo
    • You may want to check with your IT folks to see if this is enabled at your location
Additional References


automatically bumped #34

#35

Ok…I backed everything up and did a hard reset…still not connecting to work wifi…pretty much at the end of the RW rope on my phone at this point. Since my old devices had no issue connecting after removing the network and adding back, I know that it is not an IT/network issue at work…gotta be the phone itself.


#36

Sorry to hear that… this may sound kind of silly…but when you enter the password…have you tried to enable the “show password” option to make sure it is 100% the correct password… sometimes with the keyboard layout and what have you…it is easy to miss one of the edge keys and end up with the incorrect password


#37

Have shown PW every time…and entered side by side with phone n tablet…tablet has no issue connecting.


#38

Maybe your phone MAC address is somehow blocked by your company router…see if they can reset it…or check logs to see if your MAC address is blocked…maybe that could resolve it.


#39

Another option would be on your phone

Under the Developer Options
try enabling
Connected MAC Randomization
(It’s listed under the “Networking” section)


#40

I did some testing - I cannot connect to a hidden-SSID network with an X4 on Pie. The G6 Play on Oreo will do it. And others have also noticed the problem, for example: https://forums.lenovo.com/t5/Moto-X4/WiFi-Does-Not-Work-on-brand-new-Moto-X4/td-p/4149196

Tell the work I.T. that a hidden SSID is worse than no security at all. It causes devices that want to use that network to probe the airwaves, asking whether it’s around. Those probes could be intercepted by Bad Guys whose rogue Wi-Fi router then impersonates the hidden SSID network, your phone connects to it, and bam!, your phone gets hacked and/or your unencrypted network traffic is available to the Bad Guys.


automatically bumped #41