Moto Z Play can't save photos from messages

What phone do you have? Moto Z Play

What plan are you on? My Choice + 1 GB

Does your plan include data, or just talk & text? Includes data


Issue Description

Hi everyone,
I am having an issue with my Moto Z Play. Whenever I try to save a photo from Messages to my phone, I get the message “Couldn’t save 1 attachment”. This only happens with photos – I have no problem when saving screenshots sent to me.

I have tried revoking permission for the Messages app to access my device’s storage, then re-granting permission at the prompt when I try to save a photo, but no luck.

Any ideas? Thanks!

I believe last time I had this happen I went to settings - Apps & notifications - App info - messages - storage and clear cache. I may have done the same for the photos app. Then I powered it off and then back on.

Thanks for the tip! I just tried this and still no luck.

Here is a similar problem (with a solution) from the Motorola forum:

Thank you! I found this before I posted here - it’s where I got the idea to revoke and then re-grant storage access - but it didn’t work for me. I can’t find anything else on Google, either.

I don’t know if this might help or not.

Deleting photos stored in the Messages folder worked! Thank you so much for directing me to that thread. I appreciate your help.

Glad that it worked, you are more than welcome!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer