Moto Z Play Screen Flicker and Input Lag

I finally upgraded to from my trusty Moto X 1st Gen last month.

The awesome Moto Z Play celebration offer was too good to pass up. Got the phone and activated it pretty much 1 month ago.

*Loved it! *

But suddenly yesterday afternoon the phone became laggy/unresponsive and the screen starting flickering/flashing.

I’ll try to explain those more clearly.

- Lag:

Phone worked great until yesterday afternoon; suddenly became very laggy where the touchscreen inputs were extremely sluggish. For example, if I scrolled or tap on the screen, the response would take a second or two to register.

- Screen flicker:

At the same time, the screen started flickering/flashing periodically. For example, while trying to use the lagged touchscreen UI, the screen would looked it flashed on/off every 5-10secs or so.

Occasionally the screen UI would suddenly go corrupt, with menu items and the like not displaying at all or showing some weird static. I took a picture of one such instance to share:

http://tinyurl.com/zcjadlq

Things I tried:

  • Reboot phone…still buggy.

  • The Internets suggested a cache-clearing might resolve the weirdness. I went to thru the Settings=>Storage menu and deleted the cache a couple times. Still buggy.

  • The Internets noted that buggy app update installs could cause problems; I went and deleted a bunch of apps, noting that there were some recent auto-updates right around the time I noticed the issues. Additionally I uninstalled updates for Google service apps as well (Gmail, etc). Still buggy.

  • I tried booting into Safe Mode to see if the issues persisted…still buggy.

  • I tried booting into the Android Recovery Mode; but I found that when I tried to select menu options (done with the volume up/down), this screen also got suuuupeerr buggy and weird. Every click of a volume button to select something resulted in the screen glitching up. I exited out of there without doing the Android system cache clearing; I couldn’t find the menu option due to the ditzy menu display.

  • Finally I decide to bite the bullet and try the Factory Reset. I performed thru the phone regular settings menu; it goes thru the whole reset process, wipes all data, etc.

Fingers crossed…still buggy. I did not sign in to any of my accounts or install any apps. Not even the republic app is on there now. But no luck. The screen flicker, the terrible touch input menu lag, the screen glitching, was all still there.

I took a 1-min video here:

https://youtu.be/o-rsdnBvktk

I still haven’t signed into any accounts or downloaded any of the apps since resetting the phone…yet I can still receive calls. That’s odd…not even the Republic app is on there. I guess once a phone sim is activated, that part of it just works regardless?

Anyways, I don’t know what caused it; a bad app update should have been rectified by the factory reset. It seems like it may be a hardware thing after all? But how so sudden? Was working with no issue like an hour beforehand.

Its a mystery. Any ideas or steps to suggest??

Thanks for any time and wisdom

I’ve been poking around with android modding for about 6 years. Assuming you didn’t root your device and install custom firmware (not many options for that at the moment for the MZP anyway), you’ve done everything I can think of to resolve this, if it’s a software/firmware problem on the device. My guess is that you have a hardware issue – I’d recommend getting in touch with Motorola/Lenovo and start a warranty claim.

They’ll probably ask you to go through the factory reset rigamarole at least before doing so. I’ve never done a warranty claim through Moto, but from what I hear they are pretty good to deal with.

Good luck.

Dan

From your documentation of the problem it’s evident you’re thorough!!!

Hopefully Motorola was as thorough when they wrote the Help app? Possibly their Hardware Test could be used to check?

It is the App with the big Blue ? Icon and is titled ‘Device Help’ and it’s under ‘Fix’

Cheers DanD and JBen!

Yeah I’m definitely thinking its hardware and I have no recourse but to ship it over to Motorola :\

I’ve been doing that thing last couple days where I’m just “hoping” it will suddenly work like normal after a reboot hahah. Don’t want to be without the phone for weeks…these things are like a part of our body now.

DanD:

Not ever rooted, nope. The one step I found online that I did not try was to clear cache via the Recovery Mode. And that was because the Recovery Mode itself was glitching out on me! Currently chatting with RW Support on this, but indeed looks like I got to go thru Moto…

JBen:

Cheers for pointing me to “Device Help”! Never noticed that app before. It was not able to point me to issues this time, but its cool to know its there and kinda fun to toy with. Will def keep it in mind for future debugging purposes.

At the least, its cool that we are collecting some ideas and trouble-shooting suggestions in one post for other RW Users. Hopefully helps somebody else who encounters a similar issue!

Update; back and forth with RW team resulted in strong suspicion of hardware problem.

A replacement Moto Z Play was sent out and I will send the glitchy one in. Fingers crossed that the replacement proves as hardy as my 3-yr-old Moto X Gen 1 (which I turned back to for a week while the Moto Z spazzed out)

Besides the obviously frustrating issue, the Moto Z Play model itself is quite excellent with seriously fine battery life. Lovely screen, build feels great. Biggest issue for some would be the size and heft. Overall I would still recommend it (and yes, its got a headphone jack).

Message an
Expert customer