Moto Z3Play suddenly will not connect to public wifi

Moto Z3 Play, 64GB. My Choice Talk&Text.
At the coffeehouse that is my place of study, I usually get on their WiFi with my Moto, using is
in my studies. Today the Moto would not open/display the login for the public WiFi. The WIFi was functioning normally for other patrons. I’ve checked through settings and rebooted several times.
The login still would not come up. ?


Hi @gardyw and welcome to the Member Community. Have you tried a “forget network” and re-connect just in case something got corrupted in the password (or password was changed)?

It’s possible your phone has connected to the Wi-Fi, but since you haven’t acknowledged their captive portal agreement, you don’t have access to the internet. The Wi-Fi connection will block the use of cellular data, but the captive portal agreement will block the use of the Wi-Fi!

A good troubleshooting step.

1 Like

Thank you freddyp,
I have tried the forget and reconnect remedy, without success. I need to further describe the action
of my phone. A the public WiFi: phone brings up the available network, click on that network, phone brings up screen with “data file html” and no login password box.
And can get no further.
Something?

Message an
Expert customer