MotoG4 not showing caller ID and can not answer incoming calls


#1
Can't answer calls

What phone do you have? MotoG4

What plan are you on? my choice + 3GB

Does your plan include data, or just talk & text? data


Issue Description

I'm not real sure when I noticed this, I'm guessing 10 days ago, but I'm not able to answer phone. I really don't use the phone app much so didn't pay that much attention to it. I can dial out ok but noticed I could never get to a call in time to answer. It usually goes to voice mail in 4 rings and I usually answer at 3 1/2. Well, I was expecting a call and when I could not get it to answer, I started to wonder. Well today I've decided to try to find the answer and have troubleshooted the following. The caller ID does not appear at all whether its sleeping or awake. While sleeping, the phone is paralyzed. The power button or touching the screen will not do anything. If phone is awake, all functions seem to work except the phone. I have got to answer but only when the phone is awake, and I open the phone app, and I get a prompt to "return to phone call". I've rebooted the phone countless times, tried to uninstall and reinstall republic app (not sure if that was successful for all it allowed me to do was update). I've read countless forums and even chatted with Motorola and it was quickly suggested i reset to factory specs which i'm not comfortable with for I may loose "stuff" I really don't want to loose. Is anyone having the same issues or can anyone guide me to correct this problem? Thanks

#2

As a troubleshooting measure, please restart the phone in Safe mode. This will boot the phone without any memory resident third-party apps. If something changes, that would suggest a third-party app is causing the problem when not in Safe mode. If the same behavior persists in S afe mode, then a factory reset may, unfortunately, be your best option. Perhaps someone knows of this issue and can offer a better solution. But, try Safe mode and see what happens.


#3

Do you mean ever, or specifically when the phone is ringing?

Do you see any indication at all on the screen that you have an incoming call? If not, it’s like just a matter of changing a notification setting.


#4

no indication what so ever there is an incoming call…,I can answer it if I do the following… A) the phone is awake, B) open phone app and , C) choose number 2 from the following… 1) use touch tone keypad 2) return to call in progress, 3) add another cal… to complicated to answer a phone call…i did the safe mode reboot and the same problem persists…i hope i painted a decent picture… thanks for helping in advance


#5

and how do i change notifications… i looked into this but got lost


#6

I’ll write it up for you in a second, I just need to get the same phone from our lab to make sure I get everything right.


#7

problem solved… phone app was blocked… not sure how or why… thanks for the help southpaw and beachb


#8

Glad you found it!

For others who might experience the same issue, the setting is in:
Settings > Notifications > Phone


#9

I’ve notice multiple notifications setting that were some how mysteriously changed on more than one of my RW 3.0 phones over the past several months. Is the RW app somehow inadvertently making these changes? We know it has a lot of control over our phones. Is this something folks with other providers are also seeing?

:flight_departure:


#10