Motorola Does not support their products


#24

My problem is that they sent us a replacement phone and within 5 - 6 months the replacement phone has the same phantom touch issues. They should replace the replacement phone that has a “known issue” and the same exact issue the first one was replaced for. It’s not that my phone is 2 years old and I broke it and want it replaced.


#25

Quite frankly, I despise the Moto G Play that I purchased a year ago. It is worse than the Moto G4, and I thought the new phone would be an UPGRADE - not. It has some awful ‘quirks’, such as the screen turning off (for several seconds) while you are trying to place a call, the pitiful ‘speakers’, the fact that purchasing accessories (cases, in particular) is almost impossible - Motorola doesn’t even carry cases for it! I can’t afford to buy one of the Samsung phones - the prices are horrid. The reason most of us go with Republic is to keep the costs down, so paying $600 to $1000 is out of the question, not to mention that I can’t afford a new phone every year or two. I am seriously considering a different carrier since the phone compatibility is so limited. I gave the Moto G4 to hubby, and he can’t add contacts and have them save - every single time he adds co-workers to his contacts, it APPEARS to ‘take’, but the next time he tries to call them, they are no longer in the contacts list. He asked Republic for help and did what the volunteer ‘tech’ told him, but nothing has worked and he still has the same problem. We are also tired of the Republic ‘app’ wanting to update every month. That gets old, fast. I’ve disabled several apps that I don’t use and don’t trust, but every time the Republic app ‘upgrades’, those apps are active again. I don’t USE YouTube or Facebook or any number of other apps, but they won’t stay turned OFF. I’m just getting browned off on Republic and Motorola.

Sorry. I’ll sit down and shut up now.


#26

I’m sorry you’re having these experiences. The Moto G Play is the low-end of the Moto G4 line. The G4 sits above it in the line with more memory, a better processor, a better screen, etc. The Play was never intended to be an upgrade to the G4 (it is a downgrade in the Motorola line as the most basic “G” phone they offer).

The Republic App is going to ask to upgrade each time Republic releases a new feature, security fix, bug fix, etc but it updating has nothing at all to do other apps updating or reenabling. It can be hard to disable “built-in” apps, but if you’re actually disabling completely (through Settings – Apps), they should not be reenabling expect perhaps when Motorola releases a new system update for the phone.

As far as your husband’s phone goes, I’ve most often see this happen when there are multiple accounts trying to sync contacts to the phone. For instance, having the phone connected to both a Google and a Yahoo account and having both setup to sync contacts. Is it possible this is the case?

The G4 Play has plenty of accessories available. A quick search finds dozens of case choices: https://www.amazon.com/s/ref=nb_sb_noss_1?url=search-alias%3Daps&field-keywords=g4+play+case&rh=i%3Aaps%2Ck%3Ag4+play+case ranging from a few dollars to highly durable cases around $20.

As far as the speakers go, I’ve found them to be pretty average for a $100 phone. A $100 smartphone is the most basic of basic entry level devices in today’s market.


#27

$100? I paid more for the Play than the first one!


#28

Are you sure you have the G4 Play? It was designed and released as Motorola’s most basic G: https://www.motorola.com/us/products/moto-g-play

When originally released it was $149: https://www.phonearena.com/news/Motorola-Moto-G4-Play-launches-on-September-15-in-the-US-costs-as-low-as-99.99_id85061 and the price dropped pretty quickly from there.

The G4+ was a lot more expensive than that.


#29

@Louisdi brings up a good possibility.

Alternatively, if you are positive your current phone is a G4 Play, is it possible that your previous phone may have been an older model of the G (a la the Moto G3)? That would make sense based on your previous statement that you thought the G4 Play would be an upgrade & that you paid more for the G4 Play than your previous Moto G.

Either way, our support team would be more than happy to try to help with any issues you may be having! If you haven’t opened a Help ticket, and aren’t able to find assistance here in our wonderful Community, I would certainly encourage you to open a ticket with us!


#30

I’m betting it’s a Moto Z Play.


#31

nicholasb, sorry about your problems with the G4+. I have been with Republic for about 3 1/2 years, first with a Moto X 1st gen, which quit on me after 3 years. I got my G4+ in January, and have had no problems with it at all. I love the extended battery life! I suppose many would not be satisfied with the G4+ but foe me, primarily as a phone and to check email, it’s just right.


#32

Feel your pain. Sorry you are going through this.

For a workaround - it works for me - Settings, Developer Options, Force GPU rendering. And set Display adaptive brightness on with display brightness less than half. This may reduce battery life a little but I have not noticed.


#33

For those interested in exploring Developer Mode options … use a bit of caution, keep track of what you changed in case you need to revert. Some options like RTL will make things difficult for most of us (RTL is Right to Left)

Enable
Settings -> About Device and scroll down to the Build Number. Now, tap on your “Build Number” seven times, and you should see a toast notification pop up saying " Developer mode has been enabled."


#34

Republic is no better their return policy is ■■■■!


#35

Hi @Sandy,

I’ve reviewed your ticket history, but cannot discuss the details publicly in our Community.

Our return policy does not include your specific situation, but we would have been glad to work with you in a support ticket on the matter. It’s something we’d need to work with you on before the phone is returned. I am asking our team to take a look at your situation now.


#36

No, not the ‘Z’. The hype when I was looking at phones said it was great, terrific, rah, rah. What it IS I’m not allowed to say in a public forum. The screen goes dark for no reason when you are trying to make a call. Sometimes you can get it back up, sometimes not, but the call is shot. I have to reboot 3-5 times every DAY, because I get error messages that ‘something is blocking…’ and can only make voice calls, no text, no GPS - nothing. I try sometimes to send a text message. It won’t GO. I resend 7 or 8 times. Nope. I have to reboot again. The ONLY thing I like about the phone is the picture quality. That’s it. I don’t stream anything. I don’t play games. I use far less than a gig of data every month. I HATE this phone.


#37

Hi @debraw.axxxft,

Have you tried to work through any of the issues you’ve listed with our support team? They may be issues that can be resolved. For example, often when we see call screens go dark in a call, it’s because a case, cover, or something is blocking the proximity sensor.

The “Something is blocking” message may have to do with the Wi-Fi network, and we have members here in Community who are very skilled at helping to troubleshoot that. It could also be due to an app on the phone.

Do you have any apps that claim to save your battery, boost the phone’s performance, or protect the phone from malware? Do you keep Bluetooth enabled?


#38

I see that others are troubleshooting with you in one of the other topics in which you posted.

I’m going to lock this topic just so we don’t start troubleshooting the issues in multiple conversations. We need to focus the conversation in one place.


#39