MotoZ Play - Getting Restart Camera message

Camera will not take shot. Immediately shows a message to 'Restart Camera" Have tried:

  1. rebooting phone - nothing
  2. clearing cache on camera app - nothing
  3. tried clearing cache on phone storage - nothing
  4. at same time, some apps will not function. tried uninstalling and installing apps again and cannot get apps to install from Google Play Store.
  5. after every change I’ve made, i have restarted the phone with no luck
  6. running android version 8.0.0

What is happening and any known fixes out there?

Motorola’s troubleshooting for the camera restart error can be found at:

Hi @thomasr.crarwy
Welcome to the Community!

Try going to your apps and look for one called Device help. That should have a test for the cameras in the hardware section. If you don’t see a section for the camera it could mean a hardware failure (from what I read in a Moto forum).

Hi @thomasr.crarwy,
Are you still having trouble with the Z Play?
Were you able to get the camera working and apps installed from the Play Store? :thinking:

No - I’ve tried everything except removing apps one at a time. The one concern I have is a book library app that I’ve been using for years now. I’m afraid that if I factory reset the device that all this info will be lost as I’m not sure if the data resides on the external card or internal. Another unusual thing happening now is I cannot update any apps. The internal memory is at 21.6 gb but the device has a 32 gb memory. What is up that? Camera needs to be restarted and I can’t update any apps… Hmm - time for a new phone? What do you think?

What is the name of the library app? Maybe we can dig online to see how it works.

Do you have another Android device that you can install the library app on, sign-in and see if your data is restored? Maybe ask a friend with an Android phone if you can install the app and use your credentials for the app login?

Once we figure out how to handle your library app we can work on resetting your phone. The other issues you write about make me thing that you have an SD card installed as “internal storage” as opposed to “portable”.

Once you check that your phone is backed up I would do the factory reset and reformat the SD card as Portable.

I think it’s fixable :slight_smile:

ThomasR - you sent a message yesterday mentioning something about setting the microsd card to internal instead of portable. Why does this make a difference?

And you asked what app I was using: Book Library D. Hardy in the google app store.

Book Library D. Hardy google app store.

Ill try downloading to another android phone I have. This app works sometimes and sometimes it doesn’t. Ill let you know how that goes.

Other question I have is regarding the microsd card. It is set up as internal storage I believe. Is that a problem at this juncture?

What is the name of the library app? Maybe we can dig online to see how it works.

Do you have another Android device that you can install the library app on, sign-in and see if your data is restored? Maybe ask a friend with an Android phone if you can install the app and use your credentials for the app login?

Once we figure out how to handle your library app we can work on resetting your phone. The other issues you write about make me thing that you have an SD card installed as “internal storage” as opposed to “portable”.

Once you check that your phone is backed up I would do the factory reset and reformat the SD card as Portable.

thomasr.crarwy:

time for a new phone? What do you think?

I think it’s fixable :slight_smile:

Good morning @thomasr.crarwy, :slight_smile:

I looked at the “Book Library” app in the Play Store and good news! It has backup and restore capability. It says:

"Wide range of export and import formats to help you get your Books in/out of the app.

Backup and restore functionality built in (to Internal storage); auto backup frequency or no auto backups, change where backups go
No restrictions on backups, can be copied between devices. Cloud backups coming soon."

I would go into the Library app and make that backup and save it out of the phone for restoring when we get your phone fixed up.

Good question! :slight_smile:
Here is my answer I gave a previous Member that had similar issues:

Now - the Library App on the good device is acting up. It keeps closing after trying to change “Device Storage Location”. The app just launches into this mode and then keeps trying to update(?) device storage location? The app tries to upload but is hung up on 3/3 something. When I close the app and reopen it, it will automatically go back to this screen even after restarting the device.

The last time I tried to back up the library to another device, there was a problem trying with syncing to each other. One device could not find the other even it they were both on the same wi-fi network.

The app works just fine on other device.

Good morning @thomasr.crarwy, :slight_smile:

I looked at the “Book Library” app in the Play Store and good news! It has backup and restore capability. It says:

"Wide range of export and import formats to help you get your Books in/out of the app.

Backup and restore functionality built in (to Internal storage); auto backup frequency or no auto backups, change where backups go
No restrictions on backups, can be copied between devices. Cloud backups coming soon."

I would go into the Library app and make that backup and save it out of the phone for restoring when we get your phone fixed up.

thomasr.crarwy:

you sent a message yesterday mentioning something about setting the microsd card to internal instead of portable. Why does this make a difference?

Good question! :slight_smile:
Here is my answer I gave a previous Member that had similar issues:

https://forums.republicwireless.com/t/moto-g7-power-cant-install-new-apps/30638/6?u=supert

Let me see if I have all the pieces of this puzzle right :face_with_monocle:

Your main phone (the Z Play) has been acting wonky…
Things like:

  • The camera malfunctioning.

  • The Play Store malfunctioning

And a Library app that as you say:

(Also sounds wonky) :wink:

It sounds like you have the app on a 2nd device, “the good device” but it is not finishing the sync.

If I have this correct…let’s first work on the “good device” and get the sync completed.

First I would try going into your “good devices” settings and tap on Apps & notifications > see all ## apps > and then find the Book Library app and tap on that. Then tap on Storage & cache. You should see something like the following screen:

Please try taping on “Clear cache” only.
I would be afraid if you tapped on “Clear storage” it would wipe your Library data and start the app fresh and new, so let’s NOT try the one :wink:.

Then, I would like you to reboot the “good device”, and try backing up the app again once it restarts.

Once you have a working copy of the app (with your library), on a device other than the Z Play we can work on that phone.

The Z Play seems to be suffering from a issue with your SD card. All the issues you first reported I believe is due to the card being formatted as part of the phone internal memory. I think the solution once we try to have your Library app data safe, is to reformat the SD card as portable. I’m not sure is that will mean a Factory Reset or not. But let’s got go there yet :wink: .

Good news and bad news:

Good - was able to transfer library app data to older android with several duplications of shelves. Yes - this is app is wonky but the best I’ve found for my needs. I tried emailing the data but the app doesn’t seem to send the email. I think I was able to save a backup though on the old android device.

Bad - i accidentally cleared the data on the good device. I was clearing the cache and the app went haywire; flashing screens and when the app stopped flashing - my thumb happened to be on the clear data button and “poof” all gone. Hopefully, the transfer back will work. This app seems to have a hard time with syncing by wi-fi or bluetooth. If all fails, I guess I can input the library again. BTW - do you recommend any library app that you know of or like to use?

So next step is to reformat sd card as portable? I have also saved all photos and videos to my laptop. Anything else I should back up? Not really sure if contacts are backed up.

Let me see if I have all the pieces of this puzzle right :face_with_monocle:

Your main phone (the Z Play) has been acting wonky…
Things like:

  • The camera malfunctioning.

  • The Play Store malfunctioning

And a Library app that as you say:

thomasr.crarwy:

This app works sometimes and sometimes it doesn’t

(Also sounds wonky) :wink:

It sounds like you have the app on a 2nd device, “the good device” but it is not finishing the sync.

If I have this correct…let’s first work on the “good device” and get the sync completed.

First I would try going into your “good devices” settings and tap on Apps & notifications > see all ## apps > and then find the Book Library app and tap on that. Then tap on Storage & cache. You should see something like the following screen:

Please try taping on “Clear cache” only.
I would be afraid if you tapped on “Clear storage” it would wipe your Library data and start the app fresh and new, so let’s NOT try the one :wink:.

Then, I would like you to reboot the “good device”, and try backing up the app again once it restarts.

Once you have a working copy of the app (with your library), on a device other than the Z Play we can work on that phone.

The Z Play seems to be suffering from a issue with your SD card. All the issues you first reported I believe is due to the card being formatted as part of the phone internal memory. I think the solution once we try to have your Library app data safe, is to reformat the SD card as portable. I’m not sure is that will mean a Factory Reset or not. But let’s got go there yet :wink:.

Ok, well at least it sounds like you got some sort of copy to an older device. :grin:

I’m sorry I don’t use or have a recommendation for a Library app, however those in the Community reading this post are welcome to chime in with a opinion. :slight_smile:

Great! You can confirm your contacts are backed up to Google by clicking here while signed into your Google account: contacts.google.com

Text messages are also something you might want backed up. That can be done using this piece of software: sms backup and restore

I’m hoping that the backups are not needed since we are only reformatting the SD card.

Now…if you’re ready… go ahead and try reformatting the SD card as portable. Then reboot the phone and see if it still misbehaves (don’t worry about the Library app just yet), we want to make sure the Z Play is back to normal first :wink:

Here is some info from Motorola on SD cards for your phone:

Let us know how it goes :crossed_fingers:

ok - i’ve gotten as far as reformatting the sd card. after reviewing the link you sent, i am not seeing an option to reformat from internal storage back to portable storage. What am I missing?

SUCCESS!!! Camera is working again and Book Library app is intact but without images. Those can be uploaded again for the back up I presume.

However, the sd card now says it is unsupported. Do I need to remove and reinstall as a portable storage?

Great @thomasr.crarwy !
The app’s creator says you can restore so… I can only go by that :wink:

That is worth a try. :slight_smile:
Here is a post in the Lenovo Community with someone trying to do the same thing and the solution. (If it continues to say the card it not supported it might be time to dump that card)

You’re doing great! Sounds like you’re close to getting your moto Z Play back up and running! :slight_smile:

But - the card is a little over a year old. Lemon - you think?

If I were to try this card in my digital camera and it works - do you think the problem is the card IN the motoz device because of the motoz device software/applications? I’m also thinking that buying another sd card will result in the same issue after awhile. Specifically, is it the motoz device causing the problem or if Android updates with regard to the motoz device will cause continual issues from now on since this issue started all of sudden (I believe) after an Android update on the motoz device recently.

I would try taking the SD card out of your phone and see if it continues to act normally. If it does, go ahead and pop the card into your camera and see what happens. You might even have the camera reformat the card and then move it back to the phone and see if you can reformat it again in the phone. (As portable) :wink:

If you do look at getting a new card please take note (this was from the support doc link I had posted)

Message an
Expert customer