My calls are getting a busy signal!

#1

Hey everyone,

There is an option on some of the 3.0 phones that cause outbound calls to ring as busy when they shouldn’t be. (Inbound calls and calls on WiFi should work just fine.) The option is one that hides your caller ID from being shown in outbound calls, but it also breaks our specialized calling flows. We will eventually fix this globally, but in the meantime follow the steps below to get your device back to working.

In general the setting exists in the dialer. Go to the overflow menu at the top right and choose Settings (or similar). The option will be in one of those menus under something like “Caller ID”. You should choose the setting “Network default”.

On the Samsung S6 or J3:

  1. Open the Dialer and tap on “MORE” on the top right, then “Settings”
  2. Tap on “More settings” and wait for the screen to load
  3. Tap on “Show my caller ID” and change it to “Network default”**
    **

On the Moto X Pure Edition:

  1. Open the Dialer and tap on the three-dot overflow menu in the top right corner; choose “Settings”
  2. Tap on “Calls”, then “Additional settings” and wait for the screen to load
  3. Tap on “Caller ID” and change it to “Network default”**
    **

Note: if “Network default” was selected and you’re still having problems, try choosing “Show number” in the final menu.

If you need help on a device that isn’t listed here, please comment below for additional help.

3 Likes

#2

If my calls are working normally on a Moto X Pure with the setting set to “Network Default”…do you still recommend that it be changed to “Show Number”?

0 Likes

#3

If it’s working then I wouldn’t touch it.

Edited post to defer to “Network default” first.

4 Likes

#4

Thank you!

0 Likes

#5

Interestingly when I enable the Hide number option on my J3 nothing happens. By that I mean the call rings through and the number isn’t hidden.

3 Likes

#6

Interestingly when I enable the Hide number option on my J3 nothing happens. By that I mean the call rings through and the number isn’t hidden.

Did you try the call on both WiFi and cell?

3 Likes

#7

Has there been an update to this??

I did not want my cell phone # showing when making outbound calls. I selected the option to hide my number in the advanced settings menu. Now _all ___ outbound calls ring busy. I tried several numbers including a land line number and it rings busy. When I make a call over wifi , the caller can be reached BUT my number can be seen.

Any updates?

0 Likes

#8

Hi @richardm.hsmcfk,

I’ll leave it to @kwhite or @seanr to advise what may or may not have been updated on Republic’s end. In general, it’s not possible to use one’s phone settings to block their Caller ID from being shown with Republic’s blended WiFi/cell service.

It is possible to block Caller ID on a per call basis by prepending *67 to the number being called. More on that here: Make and Receive a Phone Call – Republic Help. Quoting:

You can now block your caller ID from being displayed on calls that you make. This is done by dialing *67 before you dial a number when making a call.

Note: You will need to dial *67 before each call you want to block.

1 Like

#9

@richardm.hsmcfk This work is not prioritized currently. As @rolandh said, you’ll have to dial *67 before each call you want to block.

Kyle

3 Likes

split this topic #10

2 posts were split to a new topic: Calls are getting a busy signal

0 Likes

closed #11
0 Likes

Message an
Expert customer