My Contacts Aren't Syncing

I opened https://contacts.google.com. Only 3 of my 80+ contacts are shown. I have the setting on my phone for automatically syncing to Google set to “on.” What else should I do?

Hi @Voyager,

First, make sure you have only one Google account on the phone. If you have more than one, the contacts may be synced to a different account than the one you’re checking.
(I keep two separate Google accounts on one phone and half my contacts are, intentionally, in each account.)

Then consider whether you have any other accounts that may be the source of the 80+ contacts you see on the phone. For example, do you have contacts stored in a Facebook, Yahoo, or Microsoft account?

3 Likes

I only have one Google account. I’m not storing contacts anywhere else (except on my Extend Home handset). The contacts on my cell phone were entered manually and exported to the home handsets via bluetooth. I disconnected the bluetooth after the download…

Now I’m adding new contacts one at a time on each phone. The other day was the first time I had checked Google to see whether my contacts were there. Only three, as I mentioned.

What kind of cell phone is it, and what app are you adding the contacts to?

My cell phone is a Samsung Galaxy J3 (2017). When I want to add a contact, I tap the phone icon on the home page, select “contacts,” then click “Create contact.” I don’t consider this procedure to be using an app.

It is, though. Something has to store the contact to an internal database on the handset, and figuring out what that something is might explain why the contacts aren’t syncing with Google.

Any idea if the “phone” icon you’re tapping is the Samsung phone app or the Google Phone app? I’m assuming it would be the Samsung Phone app, which would mean your contacts may be stored in the Samsung contacts app rather than the Google contacts app.

I don’t have a similar phone handy, but can try to figure it out a little later this afternoon or evening. Maybe someone in our Community will chime in with info before I get back.

I really don’t know which phone app I’m using. I would guess that it is the Samsung one, as I don’t remember selecting one or the other, and the phone probably defaults to its own. But why did 3 contacts make their way to the contacts.google.com?

Hi @Voyager,

I found a Samsung J3 2016, and I believe the experience is very much the same as what you’re describing.
It looks like the “Phone” app that comes installed has a “Contacts” app associated with it. This app has permission to download or sync your Google contacts. This would explain why it was able to read the three contacts you see on contacts.google.com and sync them with Contacts app.

When I try to save a contact for the very first time, I’m prompted to decide whether I want to save the contacts to the phone or to Google.

I’m only asked that the very first time I try to save a contact. I suspect at some point in time, “Phone” was selected on your phone, so all your contacts since have been saved to the phone.

Let’s get your contacts safely backed up to Google.

  1. Open the apps drawer. (From the home screen, swipe upward so that you see your list of all apps.)
  2. Tap Contacts to open the Contacts app. It might just open up to a list of your contacts, for me, it opened to a preview of everything it can do, and I had to tap “start”.
  3. Tap the three dots menu :dots: at top right
  4. Tap Manage Contacts
  5. Tap Move contacts from phone. It will tell you how many apps that are saved on the phone will be moved. For you that should be the 80+ that you don’t already see at contacts.google.com.
  6. Tap your Google account to select that as the destination.
  7. Tap MOVE

Since I only had two test contacts saved to the phone, it was pretty fast. I don’t know how long it’ll take to sync 80+ contacts. Once I did that, I opened contacts.google.com on a computer and confirmed they were now there.

I think that’ll work for you, to get the contacts backed up to Google. Once you’ve confirmed they are saved, let’s clear the default behavior on your phone so it’ll start saving new contacts to Google.

Open the Settings app, then tap Apps > Contacts > Storage and clear data, this will clear any configurations on the app. It does not delete the contacts. But it does mean that the next time you save a contact, you’ll be offered the option of saving to the phone or to Google. Select Google this time, to make sure all your contacts are safely backed up at contacts.google.com.

2 Likes

Thanks for this help. I can get to Manage Contacts, but there is no “Move Contacts from phone.” The choices are Merge contacts, Import/export contacts, Sync contacts, and Default storage location.

I thought export would be a good choice. It said, “84 contacts will be exported. Select where to export your contacts to.” There were 3 choices: Internal storage, SD card, or SIM card. I’m not sure which of these has the contacts presently, and I don’t know what the advantage would be to move them anyway.

I Synced contacts and set the default storage location to Google, but that didn’t add them to the Google site. I don’t know what else to do.

That’s really odd. Does it show the same Google account you’re using, and does the sync timestamp look recent?


(The word “Sync” at the very bottom of the screen is actually a button. Fooled me. :woman_shrugging: )

If you open the Settings > Apps > Google > Permissions do you see “Contacts” enabled?

Let’s try this…

  1. Export them to internal storage.
  2. Plug the phone into a data cable and connect to a Windows computer.
  3. Tap the notification on the phone to allow files to be transferred to the computer.
  4. On the computer, use Windows Explorer to view the files on the Samsung. (I select the name of the phone, then “Phone” and I see the .vcf file in the next menu, along with things like Alarms, Android, DCIM, etc.)
  5. Copy the Contacts.vcf file from the phone to your computer and put it somewhere that you’ll be able to find it again.
  6. Now, on the computer, go to contacts.google.com
  7. In the menu on the left, click “Import”
  8. Click Select File
  9. Navigate on your computer to wherever you saved the .vcf file and click it, then click open.
  10. Then click Import.
    You’ll end up with a new label on the left called “Imported on (date)”. You can mouseover that label, click the trashcan and select “keep all contacts and delete this label” if you want to get remove the label from the contacts. You’ll also end up with duplicates for the 3 that were already there, but you can use the “merge and fix” tool to clean that up.
1 Like

I don’t see this notification. When I look at Windows Explorer, I have a directory named Galaxy J3. However, the directory is empty.

I did want to share this screen from my phone with you.

It sure leads me to believe that all is well. However, no contacts show up on my computer.

I am so confused.

Well, what do you know. I’m not sure what I finally did, but all of a sudden my contacts are showing up in contacts.google.com. I’m just as confused as before, but I don’t believe in arguing with success!

I would still like to see my phone files on my computer in Windows Explorer. They used to show, and now they don’t.

1 Like

If you are not seeing the notification to change the USB connection (default is Charging)
then you are most likely using a charging-only cable…I would recommend trying again with another USB cable preferably one that has been known to be able to used for data transfer.

1 Like

Did you touch the top of the screen and drag down? I believe it’s a “silent” notification so you don’t actually see an icon or anything until you open the notification tray.

Now that you have synced your contacts :southpawpoms: go ahead and clear the data on the Contacts app like I mentioned Saturday. That way the next time you add a contact you’ll be given the option to save to Google.

1 Like

I would recommend trying again with another USB cable preferably one that has been known to be able to used for data transfer.

I am using the cable that came with my phone and that has always let me see on the computer the files that are on my phone. Just yesterday I could see my files, and now I can’t. When I connect my phone to my computer, I see “Galaxy J3” listed in Explorer, but when I open it, it says, “This folder is empty.”

With the phone connected to the computer, what do you see when you touch the top of the J3’s screen and pull down, to view all notifications?

1 Like

I see all kinds of things, but nothing about any kind of notification. But just now the strangest thing happened. I connected my cell phone to my computer. A window that I have never seen before popped up and said:

“We’re having trouble connecting
Make sure your device is unlocked, and that
you accept the notification to connect.”

Well, as I said before, I don’t see any notification. I closed out that pop-up and checked Windows Explorer (which was open right behind the pop-up). There was my phone and all its files were available.

Considering past experience, I don’t know how long I’ll be able to see my phone files. It seems like I can and then I can’t.

What do you make of this, Southpaw?

Well, I just disconnected and reconnected my phone, and already when I click on Galaxy J3, it says, “This folder is empty.”

What made it work a moment ago and now it won’t?

I really don’t know what to think of this.

When I connect this J3 (2016) to my Windows computer, multiple things happen.
My computer alerts me that a device is connected:
image
If I click that alert, I see this:
image
If I’m not careful, that thing goes away and is lost to me, but that’s okay, I usually ignore it.

Meanwhile, on the phone, there’s nothing on the screen to indicate anything is going on, except the charging icon.
image

But if I pull down the notification tray…
There’s an Android System notification that says USB for File Transfer.

With “Transfer Files” selected, I can see the contents of the folders on the phone.

I can’t explain why your experience is so different, nor why it changed suddenly. It makes me wonder if perhaps there’s a hardware failure with either your data cord or in the phone’s port that’s causing the phone to fail to recognize that the cord is a data cord.

1 Like

Hi southpaw,
Yesterday I again attempted to see my phone files on my computer. Success! However, I still don’t see any notifications. When I pull down from the top of my phone, this is what I see:
image
There must be a lot of differences between my Galaxy J3 (2017) and the one you are experimenting with (Galaxy J3 [2016] .

Message an
Expert customer