My Moto E 2d gen phone's wifi turns on by itself. How can I stop it?

What phone do you have? Moto E 2d Gen

What plan are you on?

Does your plan include data, or just talk & text? Just talk and text


Issue Description

My Moto E 2d gen phone’s wifi turns on by itself. How can I stop it?

Can I ask why you want to do that? I believe Wi-Fi will be automatically enabled any time the Republic Wireless app starts (or whenever the phone is restarted).

2 Likes

My experience has been that Wifi call quality is not as good as calls over the cell network. Consequently, I’m constantly turning Wifi off. It would be nice if I had total control over this feature. Is that possible? If so, how? Thanks in advance.

Most of the people here claim calls are better over Wi-Fi than cell. That was my experience also. If you are experiencing call quality issues like broken voice or drop outs, you might want to contact your internet provider and have them test/troubleshoot any issues. Alternately, you could run a test yourself. A test I like is at https://sourceforge.net/speedtest/ . You can even run it from your phone if you like. At the end of the test there is a “View Details” button that gives you a number of displays, including the “In Conclusion” table at the bottom that looks like this:

mos

The results can tell you what your connection is suitable for, and where the problem is occuring.

If you’re only looking to block Wi-Fi calling at home, you can likely configure your home router to block UDP port 5090. With that port blocked voice calling would be done over cellular while all your data will still utilize Wi-Fi.

4 Likes

Thanks for your help.

Perhaps a little more background info is warranted.

First, I prefer to use my laptop rather than my phone for web surfing, etc.

Second, my initial experience with Wifi calls occurred several years ago with a 1st Gen Moto E RW phone. For whatever reason, Wifi calls with that phone were unsatisfactory. That phone died a few months ago and I was able to replace it with a 2nd Gen Moto E and simply continued the practice of trying to keep the Wifi turned off. However, this 2nd Gen phone much more persistently turns Wifi on by itself. Hence my desire to find a more permanent solution that will allow me to control when Wifi turns on and off.

Third, as a result of your questions and input, I have left Wifi on for the last little while as I went about my business. Pretty quickly, a free MP3 playing App interacted in an unwanted and annoying way with the Wifi connection.

Fourth, as a result of your comments and input, I plan on doing some more experimenting with the Wifi but would really like to control it more than I have been able. Any additional suggestions are appreciated.

Thanks again for your help.

If the Wi-Fi is frequently being re-enabled by the Republic Wireless app, it could be an indication that the app is crashing and restarting. Make sure you have the latest versions of the Republic Wireless and Republic Telephony apps.

1 Like

cbwahlstrom,

I checked and I do have the latest RW App versions. Also, I’ve made some recent Wifi phone settings adjustments that I’m hoping will give me greater control. In any event, I really do appreciate all of your help. It is very much appreciated.

Best regards,

disambiguate

1 Like

Would you mind sharing what ‘adjustments’ to the WiFi phone setting?

  • If this leads to a fix it may help someone else in the future

Sure. (I’m probably being overly optimistic, but…)

Here’s what I did:

Go to :

  1. Settings
  2. Click Wifi
  3. Click three little dots in upper right corner
  4. Click Advanced
  5. Turn off “Network notification”
  6. Turn off “Scanning always available”
  7. Turn off / Choose Never for “Keep Wi-Fi on during sleep”

End

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer