My Moto-X 2nd Gen Doesn't Ring and I miss a lot of calls


#1

Ever since my Moto-X 2nd Gen was upgraded from Kit Kat to Lollipop OS my phone went from 100% Hands-free while driving to 100% Hands-On. and lately the ringer is not working so I miss a lot of calls. My wife has cancer and I can not afford to miss doctor calls. I do not want to switch carriers because I like Republic Wireless. I just want my phone to ring when there is an incoming call. any suggestions? Keith


#2

Go to the Home screen, press the volume-up button, and see if the ringer is set to All.


#3

yes, it is, but thanks for that suggestion.


#4

There are only three other things I can think of that could cause this. I’ll start with the easy one:

  1. It is possible to set an individual contact to go directly to voicemail.

  2. A call blocking app was installed that isn’t working properly.

  3. You have an ASUS router and WMM-APSD is enabled. This can cause the problem you describe if you don’t have good cell service at your home.


#5

every thing seems to be normal


#6

There is a troubleshooting section in this document:

Make and Receive a Phone Call

If those steps don’t resolve the problem click on Help at the top of this page, scroll down, and open a service ticket.


#7