My Moto Z4 Play phone 'do not disturb' feature issues

What phone do you have? Moto Z4 Play

What plan are you on? 1 GB data plan

Does your plan include data, or just talk & text? Data


So the ‘do not disturb’ feature on my new MotoZ4 Play phone doesn’t silence the ring alerts. I have gone into the ‘do not disturb’ settings to only allow alarms and calls from my starred contacts. I have it selected on ‘no sound for notifications’. But I still get sound push notification sounds from some features such as Whatsapp, the weather app when do not disturb is on, yet I have all these settings selected. Any ideas?
Thank you, Joe

Issue Description

Hi @jmeller19,

Would you be able to share a screenshot of your do not disturb settings? Someone may see something there that would provide a clue to what’s going on.

1 Like

Thanks, I’ve attached here and will do in the forum later.





1 Like

I’m actually not sure how to post screen shots on the forum… Don’t see anything for attachments

Hi @jmeller19,

No need to post them in the forum, your E-mailed replies automatically post in our Member Community, so the conversation continues there, and your screenshots are visible there.

1 Like

This may be intentional, but the only thing I see in a first examination of your screenshots, is that while it appears you have all the settings for Do Not Disturb correctly configured for silence, and even no visual notification, you do not have Do Not Disturb currently enabled.

If you tap the “turn on now” button in your fourth screenshot, do you still get notification sounds?

If I do that, then that actually turns on the’ do not disturb’ feature, which I don’t want on when I’m awake or not in a meeting. But when I do turn it on, this is when I’m having the problem of these disturbances happening that shouldn’t be happening.

Hi @jmeller19,

I don’t have a Moto Z4 Play available for testing, but the Moto Z4 in our lab obeys the Do Not Disturb settings, so I’m not able to replicate what you’re experiencing.

If you use the volume-down button and then tap the bell icon until it shows a crossed-out bell, do you still have audible notifications?

No I don’t have that problem when I manually silence it that way… That is the way I’ve been doing it but it is frustrating that it won’t work correctly with the do not disturb option. Hopefully someone else will be able to give some input. Thanks though.

I’m gonna throw a couple of odd suggestions out (it’s an odd issue :wink: )

  1. Have you restarted your phone lately to see if that helps?

  2. Even tho the setting is correct (image below), try toggling it to “no sound from notifications” and then back to “No visuals or sound from notifications” and test it again.

1 Like

a long shot but have you verified the 3 rules used to turn the feature on automatically are (I believe the default should be weekday, weekend, and event) each rule should be check that they don’t conflict

Thanks for your input…I have restarted the phone many times and that doesn’t fix anything with this. I’ll try the toggling suggestion.

Yes, I’ve checked those and they do not conflict. Thanks for the suggestion.

Check the notifications that are trickling through if they are set to Override DND

For example…for Whatsapp

Go to Settings -> Apps and Notifications
Tap on Whatsapp
Tap on Notifications
Tap on Message Notifications
Tap on Advanced
Check if the option to “Override Do Not Disturb” is enabled

Thank you for your suggestion. but when I go into settings for WhatsApp I tap on notifications and from there there is not an option for advanced notifications. I have attached screenshots of this page

Instead of starting in the Whatsapp app’s settings, open the Android settings menu, then follow @amitl’s instructions and see if the override option is there.

1 Like

okay I understand now. I have done this and the override option is not turned on so I’m not sure what the problem is. Shouldn’t the ring volume be needed also when do not disturb is turned on?

I’ve included here a screenshot of the volumes when the Do not disturb option is turned on. as you can see the media volume is muted but the ring volume is not. so I’m not sure why the ring volume does not get muted when I turn on the do not disturb options.

Hi @jmeller19,

No… call and ring volume remain set when you move to do not disturb, the function is just meant to override the volume setting. Otherwise the phone wouldn’t know at what volume to play the notifications you do exclude from “do not disturb.”

For example, at night, I keep my phone on “do not disturb” but I have it set so that my starred contacts still notify. That way if my daughters or one work-related contact needs to reach me, I’ll hear the phone. Everyone else is silenced. If the volume sliders were moved to the left, I wouldn’t hear my daughters’ calls.

I found this topic in the Motorola/Lenovo Community, which sounds similar to what you’re experiencing:

It doesn’t seem it was ever solved in their Community. I imagine a support interaction with their team will lead you to a factory reset of the phone, but contacting them may be worth a try.

@muerte33 have you ever experienced anything similar?

1 Like

OK, thanks. I’ll check that out.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer