My pc can log on to private wifi but x4 won't

What phone do you have?

What plan are you on?

Does your plan include data, or just talk & text?


Issue Description

I haev an x4, text and data plan. My pc can log on with no problem. I have the user name and password and that is it. My phone isn’t saticfied and won’t connect. There is more inputs required than I have.

  • Are you having to use the + Add the Network? (it doesn’t show or is a hidden network)
    • If Yes, did you perhaps then choose the Security designate 802.1 EAP
  • If you know the SSID/Network Name that the PC is logged into, just use that.
  • If that doesn’t get you going, can you provide screenshots of where you have the problem
1 Like

I don’t need to use add a network. The WiFi is displayed. when I click to enter credentials I get a list of types of connections like PEAP EAP methods stuff like that. There is a list of entries: identity, Anonymous identity and password. I put user name in identity and anon identity and enter the password. The connect is grayed out and won’t respond. I tried the other types like TTLS, PWD LEAP SIm… etc I dont’ know what any of those mean. My pc connected rigth away, even my bike gps got a network connection without entering the username. I dont understand why x4 having so much trouble. BTW, I am a retired software engr. Not IT but very pc savy.

I got it to work. I think I said to not validate and the connect command got available. Clicked it and it worked. I don’t know why this was so difficult.

What type of network were trying to sign into, the terms you quote above. afik are normally associated with Enterprise server/authentication.
Now that you connected, what does it show when you tap on the SSID/Network Name of the network your signed onto?
My X4 shows the following
Signal strength Excellent
Frequency 5 GHz
Security WPA2 PSK

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer