My phone decides when it wants to ring

My Moto G4 Play is a very smart phone.
It can make up it’s own mind when or if it will ring.

Let me explain using the latest events.

Over the weekend, I was on call for a large portion of it…

There were several times the phone went straight to voicemail and never rand and I wasn’t on it.
Another time, it says the Republic user is not available.

Each of these times, I’m sitting in my living room less than 15’ from my router and the phone is in arms length.

I verified that the volumes was set to max and that vibration was also on.

Any suggestions will be appreciated

1 Like

Just to make sure… You don’t see a 5 pointed “star” icon beside your wi-fi signal strength indicator on the top right side of your screen do you?

If you do, your phone might have somehow got into “priority” mode where depending on how you have your contacts configured may be letting some favorites thru while sending others directly to voice mail, etc.

If you do see the star, you can exit priority mode by:

  • With the phone at your home screen, press the vol up or vol-down button.
  • On the pop-up screen for volume control, select “All”

Thanks for the reply, sabrefencer.

I didn’t know about that function but I did not have the star

If it matters, all of the calls were in my contacts list

I found this by searching help, it says check to make sure your ringtone didn’t get set to none. Phone does not ring

Also remmeber since you mentioned each of these contacts were in your contacts, make sure you didn’t somehow assign an individual ringtoneof “none” for these individuals.

I forgot what happened for the individuals I had assigned unique ringtones from Zedge app. But I do remmeber when I switched to another phone I had to go in and re-download and re-connect the contacts to their new unique ringtone.

Another suggestion I saw was that sometimes people try and conserve battery by setting the WiFi to off when the phone is sleeping. This will cause the phone to try and use cell when the phone is “sleeping”, and if your cell signal is low, could cause similar issues. Try:
Settings -> WiFi -> Advanced WiFi -> “Keep WiFi on during sleep” is set to “Always”

Thanks for the continued suggestions.
Further details.
The phone rang before and after these failures.

I checked that “always” is the setting for wifi during sleep.

Not sure how to set different ringtones for individuals.
But I think I always use the default

Yeah, I’m on an old Moto X Gen 1, so my contacts are probably set up slighty different than yours. But I edit them by:

  • Opening “Contacts” app
  • Selecting a contact
  • Clicking on the edit icon (which looks like a pencil towards upper right corner).
  • Selecting the 3 dot icon (Looks like a semicolon with 3 dots)
  • Select “Set Ringtone”

Since you are on a Moto, try and make sure your Moto Assist isn’t restricting calls while it thinks you are “Sleeping”. These are what my old Moto X options look like yours may vary…:

  • Open “Moto” app
  • Click gear icon in upper right corner.
  • Click “Assist” icon
  • Mine has a “Sleeping” mode and I can double tap on it to open it.
  • There it has the ability to select a “Keep Quiet” mode to only allow proiorty interruptions, set time range etc, for sleep mode.

Or when you are at the “Assist” mode and see the “Sleeping” icon, you can press and hold “Sleeping” and a little trash can will pop up and you can click it to remove the “Sleeping” assist mode.

Update: Here is a page Republic put together for Lollipop Moto Assist:

Update 2:
Also in ASSIST where “sleeping” is, also check “Meeting” mode, it looks at your calendar, and depending on whats scheduled on your calendar also changes phone mode based on preset options.

You might also want to check out the @jben’s solution on this thread: Moto G4 not ringing on incoming calls

2 Likes

That sounds exactly like my situation, selfruler.
Except I can’t get the page to display for the solution

this is the current tip on how the manage this

2 Likes
Message an
Expert customer