My Samsung Galaxy s9 won't send texts unless to a person in the contacts list

I’m not sure if this is a Samsung issue or a Republic issue, but unless a person is in my contact list, I cannot write or send a text to that person. This is pretty inconvenient for a one-time text that I need to send. Any ideas?

Are you using Messages by Google as your messaging app?


Did shifting to a supported Google Messages app do it for you, or do you need additional help?
Other things to consider with Samsung are documented by @SuperT and can be found

Yes. I’m using what was recommended by Republic.

I was already using Google Messages. I can’t send texts to anyone who isn’t in my contact list. It tries to look for the number and then gives me something like “number not found” whenever I try to send a text out and they’re not in my contacts. Sorry it took a bit to get back to this.

Very strange. It almost sounds like some parental control is turned on.

Hi @453d2406-aae3-4a0a-b in addition to what others have suggested I’m wondering if it would be worth starting the phone in safe mode to see if a 3rd party app is causing a problem?

How to Enable Safe Mode on Samsung Galaxy Series Phones

Not sure how successful a test will be based on the Additional Note at the bottom of the link –

It’s important to note the Republic Wireless app is also disabled in safe mode for this device which may affect service while the phone is in Safe Mode.

Recommend you also check and make sure Chat is turned off in the Google Messages app

How to Disable the RCS Chat Features in Messages by Google

Others might jump in with other things to check too!

Strange indeed.

Thanks. I will give it a shot. However, since it only happens when I’m trying to text a non-contact, I don’t know who to try and text right now. Ha ha! I guess I could remove a friend from the contacts temporarily and try to text them, then add them back onto the list afterward. I’ll try that later today and get back to you.

Message an
Expert customer