My Service isn't Working

What phone do you have? Moto G Power

What plan are you on? My Choice + 1 GB

Does your plan include data, or just talk & text? data included


Issue Description

My phone service isn’t working. In the upper right corner of the screen, the icon for the bars of service is blank and there is an ‘x’ beside it. The phone works fine when connected to wifi. My RW app is up-to-date.

I would appreciate your help. I am not too tech savy so please reply in non-technical terms.

Tara

Hi @taraw.2l5bbm and welcome back to the Member Community. One of the Experts wrote a 4 step process that is pretty easy to follow. So let’s try those steps to resolve this issue:

  1. Reboot the phone in an area that has a strong cell signal. Some people have simply needed to step outside and reboot. If this fixes the issue, stop.

  2. Please ensure the data is turned on in Android Settings. Go to Settings > Network and internet> Data Usage > Under Mobile make sure Mobile Data is on. If this fixes the issue, stop. (I verified settings using one of our old Moto G6 phones so the location of your settings might be slightly different).

  3. Reset your Republic credentials by opening the dialer as if making a call and enter *#*#8647#*#* (in on a Samsung phone hit the dial button). The screen should clear, when it does, restart the phone. If this fixes the issue, stop.

  4. This one is more complicated. This step will clear out any saved connections for Wi-Fi and Bluetooth that you may have already made. We’re going to reset the network settings.

  • Go to Settings > System > Advanced > Reset Options > Reset Wi-Fi, mobile & Bluetooth (Again, I verified settings using one of our old Moto G6 phones so the location of your settings might be slightly different).

  • Read the warning, tap “Reset settings.” You will be warned a second time. Tap “Reset settings” to confirm. The process will usually take 5-10 seconds and the cellular signal bars icon will go away for a moment. Once the cell signal bars icon returns, you should reboot the phone.

Hope this helps! Others might jump in too if I’ve missed something.

2 Likes

Wow! Thank you, freddyp! Did the reboot and it’s good to go.

Appreciate your help.

Tara

1 Like

Hi @taraw.2l5bbm glad that got things working. The Community is a great place!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer