My Social Security 2FA texts stopped getting through

Thanks @erinm,

You’re also waiting for the snail-mail method, right? I’m starting to suspect that is a factor, but I’ll include your results in an update to our technicians.

@travish.3ykfmb, are you able to receive the 2FA text messages as needed now?

I just tried again and had success getting a code and a “help” reply.
It seems that the snail mail reset may cause the phone number in the online profile to be erased, because I and @selfruler had the same result. The solution seems to be a combination of re-entering the phone number in the online profile (after using the snail mail code) combined with the fix the Republic engineers applied. For others who did not request a snail mail reset, assuming my theory is correct, it would follow that the engineers’ fix has resolved the issue. Hopefully that is the case for them.


Hey ALL, earlier this week was once again able to get into account since texts started working. This evening when tried to get back into account … once again no authorization code/text. So tried the “help” bounce back … NOTHING.


I have the same result this morning. No text and no help response.

Thanks @martwiii and @travish.3ykfmb, I’ve updated our bug ticket with your test examples.

As another data point – just retested this AM. Reliably getting the expected “MySSA, for help please visit” response. Got correct message each time I tested on 11/13 and 11/18. Have not had to do the snail mail thing so don’t know if this impacts anything.

I got my snail mail and opened my account and directed it to send me emails for my security codes. I sent the “HELP” text to the 79913 short code and there was no response. It’s just quicker and easier to use the email notifications, when dealing the My Social Security account. Thanks for trying to help in this matter.



Visit my Vegan Recipe page

I tested with my Moto X4 and latest beta RW code
Failed 12 out of 30 tries, (sets of 10 each HELP/Help/help) equal failures per set

1 Like

Not working multiple times today. No 2FA texts from SSA, and no response to help message sent to 79913. This should also be investigated as part of master ticket 1798585.

1 Like

Hi @sharonr.rpyyeh,

Welcome to our Member Community, and thank you for joining the conversation. I see that your ticket has been attached to the master ticket. Thank for you adding your example as we continue to investigate this perplexing issue.


No luck here for three days. Worked as late as 11/5/19. Tried two phones, two separate RW & SSA accounts. Will open ticket.

Thanks @ceedee,

The company we partner with for messaging has escalated the issue to the company they partner with for short codes, and so far we are told that a fix is in progress. There’s no ETA, nor are there any details on what that fix entails, but we’re happy to hear that they continue to work on a solution.


Just got off the phone with SSA help desk. Her first question was am I using T mobile? Apparently many T mobile customers find their SMS blocked. (T mobile offers text message blocking for customers billed for each message). That is not my issue, however.

Help desk lady said that SSA’s history indicates that a message was sent, so they are not blocking messages to VOIP. However, I used my Google Voice number. It worked in August, but not now. After reading through the messages here I tried texting “Help” to 79913 using Google Voice - no response. Tried again using the RW number (which is T Mobile) and got an instant reply.

I requested a change. When the snail mail letter comes in a week or so I will set up both email and the RW number. I like belt and suspenders, and would add rope if I could.

I also had a chat with Wells Fargo last summer. No GV or RW, or even email for certain services like Zelle. Only work around is to buy a fob from them that displays a code that changes every 60 seconds. I have used them in the past to log in to my employer’s VPN and they work. But it’s a pain in the posterior. I changed banks instead; that’s only a one-time pain.


Just to be clear, RW numbers on Android phones are not T-Mobile (or Sprint) numbers. Republic numbers that are part of the standard service are hosted by their partner (and former parent company)

1 Like

Bandwidth does not own any cell towers, afaik. It runs calls through either T Mobile or Sprint. As I understand it, when banks or other security-sensitive organizations check a RW phone number, they learn that the number is assigned to Bandwidth as the carrier, which is classified as VOIP. That is snooty Wells Fargo’s story. It is a relief that Social Security appears not to be doing this, so the sporadic dropping of their 2FA SMS text messages is caused by something else.

Years ago I had problems getting my Google Voice number to ring my RW phone because Bandwidth handled both GV and RW. The forwarding issue seems to have been resolved, but I believe that GV is also shown as being a Bandwidth number if an SMS sender checks.

Correct, however you originally stated

and my point of clarification is that your number is completely unrelated to T-Mobile. The number is a Bandwidth number and no looking, no matter how hard, will find it in any way connected to T-Mobile.

Also correct because Bandwidth provides the infrastructure for GV numbers as well.

1 Like

Unable to receive the security code from Social Security ( in order to access my online mysocialsecurity account. This is a problem. Thanks for any help you can provide.

1 Like

Hi @Vegemom3 and welcome to the Member Community. There is already an active discussion about this issue with an open master trouble ticket.

If you are experiencing this issue, please open a ticket indicating that you no longer receive text messages from the Social Security Administration, and ask to have your ticket investigated as part of master ticket 1798585.

1 Like

Thank you. I did open ticket to be part of the master ticket. I appreciate you reaching out.


I too am not receiving 2FA codes from SSA. I have a call into them, but evidently the problem is not on their end. I do not understand to whom you requested a change. I will dig into the earlier exchanges in this thread to figure this out. At least I know which direction to dig.
What is still odd to me is that I receive 2FA codes from other sources. I hope that the earlier messages clarify why SSA codes are not coming through, and what to do about this. Thanks.

Message an
Expert customer