My Social Security 2FA texts stopped getting through

Have you tried to get anything fixed by the SSA? This isn’t an issue on the Republic end. I’d be surprised if it is solved in a year.

Not saying we should have to wait forever, but just so you guys know, the problem is apparently not with SSA or Republic.

1 Like

Hi @travish.3ykfmb,

The “content provider” for the SSA is involved in the troubleshooting as well. It’s quite a complex situation!

4 Likes

Thank you yet again, @southpaw! I (and my wife) are both stuck with this issue, still. So I have requested the snail mail reset code, to go through a New Account type process with the SSA, again. The Two Factor Authentication (or 2FA, or MFA as the SSA likes to call it) was working for me and my RW phone for months - then stopped when I needed it again.

My continuing complaint to RW is that the supposed Help Article (which is the only thing which is shown when we search for Help in the RW app, or on the main RW website) still does not Help. The article really must clearly explain that anyone with issue needs to 1) Falsely tell the SSA website that their RW phone is no longer available (therefore should be deleted from the SSA account) and consequently 2) Request a snail mail reset code be sent, in 5 to 10 business days.

Not only is this not clear in the RW “Help” article, nothing on the SSA site makes this clear. So I (and my wife) went in circles for days, trying to find how to get an email authentication. Since this seems to be so complex in the RW and SSA service provider domain that six weeks have not been enough time to fix - the two week snail mail method is the best available.

Can someone at RW get the related RW “Help” article improved to actually help?

Hi @clint_s,

I’m not going to write up instructions for the SSA workaround you’ve described in the RW Help article, because instructions to get your SSA account verified are a bit beyond the scope of a Republic Wireless help document and because we can’t test and verify the process ourselves.

I will, however, edit the article to point readers to your instructions here in Community, if you’d like to write them up clearly, succinctly, and with a focus on providing the needed instructions. We can put your instructions in our Tips and Tricks category and point readers to them, there.

3 Likes

A post was split to a new topic: Not receiving Social Security Administration 2-Factor Authentication code? How to use E-mail instead

Thanks @clint_s!

Can you add a link to where one might get started with this process of requesting a snail mail activation code?

I edited the earlier text to, hopefully, clarify. There is not a distinct webpage to request the reset code via snail mail. Text on the SSA signon page implies that we might be able to request an alternative authorization method - but that turns out to be declaring that our mobile number is not working for us, so mail me a new account setup code in 5-10 business days, to go through the SSA online account validation process, again.

Thanks @clint_s,
Your explanation is now a Tips and Tricks topic:


and I’ve added a link to your topic from our Help Center article on the issue.

May we send you a Republic Wireless T-shirt for your above-and-beyond help for our members?

2 Likes

I hear the t-shirts are really nice.

1 Like

I would be honored to have and wear a Republic Wireless t-shirt! (Large size, usually.)

Thanks @southpaw !

1 Like

I would argue there are at least 2 issues here:

  • Issue #1 is what has been discussed in this thread.

  • Issue #2 is that RW customers apparently discovered issue #1 before RW did.
    Therefore, part of the solution that RW is working on needs to include not only issue #1 but also to enhance the testing of their service to ensure RW customers are not the first to discover this type of thing.
    This issue (#2) is entirely the responsibility of RW, regardless of where the root cause of #1 lies.

Furthermore, I can tell you that my daughter abandoned RW last week because of this very poor quality experience. And I am going to abandon RW as well unless there is a real solution (not a workaround) made available to me by Jan 15.

You would like Republic to be testing the literally thousands or perhaps tens of thousands or hundreds of thousands of sites that use 2FA and whether they’re working properly? Not even a company the size of Verizon can do or does this. If they charged $1,000 a day for service they couldn’t afford to do this. Companies (including Republic) proactively monitor their own infrastructure, they monitor the service components they control, they try to detect and fix problems before their customers do. Companies do not (and can not) monitor every single other service on the planet that might interact with their network to see if it is working properly. Just not possible.

5 Likes

Have not been receiving SSA texts either. They used to come thru fine.

1 Like

My experience produced no problems.
Took a few minutes of spare time to see if I could sign into MySSA (has been several months since last accessed). Once past the login screen, I chose the option to text message to my Republic phone with security number, it arrived instantly, agreed to the new terms of service, and I was in the main page of my account.

2 Likes

Hi @teresam.5qktqz, @randym.8xvx54, @travish.3ykfmb, @davidw.d1wstp, @kennetho.wrwc6u, @Vegemom3, @ceedee, @sharonr.rpyyeh, @martwiii, @erinm, @janec.1apvlo, and others who have been experiencing this issue with authentication texts from SSA.

Our texting partner has assured us that a potential fix has been applied to the network. Please test to see if you can now receive two-factor text messages from the Social Security Administration, and let us know.

1 Like

Hi,

Thanks for the fix and update! I changed to email notification, as I could not wait for a fix. If I have to go thru the SSA change process again, I will not switch back; it takes too long. I look forward to feedback from others, as I’d like to keep this as an option in the future. Cheers!

Guys, will do it as soon as possible, home from hospital, hopefully 2 days. Thanks.

I tested this morning, and unfortunately I am still not receiving the SSA texts. The email code always arrives immediately.
FYI for others testing this, under “security settings” once you log in to your SSA account, you can enable BOTH email and text as options for 2FA. Then, during login, you can select which confirmation mode you want to use. If the text doesn’t work, you can just back up and do the email instead.
EDIT: I tried again and it worked. Not completely broken but not completely reliable apparently.

1 Like

Thanks @travish.3ykfmb,

I wonder if there was some time required on the SSA account for your update to fully process. I appreciate your testing more than once, and hope some others will chime in here :crossed_fingers: so I have some understandable results to send back to all the teams who have been working on this.

1 Like
Message an
Expert customer