My Social Security 2FA texts stopped getting through

A post was split to a new topic: Not receiving Social Security Administration 2-Factor Authentication code? How to use E-mail instead

Thanks @clint_s!

Can you add a link to where one might get started with this process of requesting a snail mail activation code?

I edited the earlier text to, hopefully, clarify. There is not a distinct webpage to request the reset code via snail mail. Text on the SSA signon page implies that we might be able to request an alternative authorization method - but that turns out to be declaring that our mobile number is not working for us, so mail me a new account setup code in 5-10 business days, to go through the SSA online account validation process, again.

Thanks @clint_s,
Your explanation is now a Tips and Tricks topic:

and I’ve added a link to your topic from our Help Center article on the issue.

May we send you a Republic Wireless T-shirt for your above-and-beyond help for our members?


I hear the t-shirts are really nice.

1 Like

I would be honored to have and wear a Republic Wireless t-shirt! (Large size, usually.)

Thanks @southpaw !

1 Like

I would argue there are at least 2 issues here:

  • Issue #1 is what has been discussed in this thread.

  • Issue #2 is that RW customers apparently discovered issue #1 before RW did.
    Therefore, part of the solution that RW is working on needs to include not only issue #1 but also to enhance the testing of their service to ensure RW customers are not the first to discover this type of thing.
    This issue (#2) is entirely the responsibility of RW, regardless of where the root cause of #1 lies.

Furthermore, I can tell you that my daughter abandoned RW last week because of this very poor quality experience. And I am going to abandon RW as well unless there is a real solution (not a workaround) made available to me by Jan 15.

You would like Republic to be testing the literally thousands or perhaps tens of thousands or hundreds of thousands of sites that use 2FA and whether they’re working properly? Not even a company the size of Verizon can do or does this. If they charged $1,000 a day for service they couldn’t afford to do this. Companies (including Republic) proactively monitor their own infrastructure, they monitor the service components they control, they try to detect and fix problems before their customers do. Companies do not (and can not) monitor every single other service on the planet that might interact with their network to see if it is working properly. Just not possible.


Have not been receiving SSA texts either. They used to come thru fine.

1 Like

My experience produced no problems.
Took a few minutes of spare time to see if I could sign into MySSA (has been several months since last accessed). Once past the login screen, I chose the option to text message to my Republic phone with security number, it arrived instantly, agreed to the new terms of service, and I was in the main page of my account.


Hi @teresam.5qktqz, @randym.8xvx54, @travish.3ykfmb, @davidw.d1wstp, @kennetho.wrwc6u, @Vegemom3, @ceedee, @sharonr.rpyyeh, @martwiii, @erinm, @janec.1apvlo, and others who have been experiencing this issue with authentication texts from SSA.

Our texting partner has assured us that a potential fix has been applied to the network. Please test to see if you can now receive two-factor text messages from the Social Security Administration, and let us know.

1 Like


Thanks for the fix and update! I changed to email notification, as I could not wait for a fix. If I have to go thru the SSA change process again, I will not switch back; it takes too long. I look forward to feedback from others, as I’d like to keep this as an option in the future. Cheers!

Guys, will do it as soon as possible, home from hospital, hopefully 2 days. Thanks.

I tested this morning, and unfortunately I am still not receiving the SSA texts. The email code always arrives immediately.
FYI for others testing this, under “security settings” once you log in to your SSA account, you can enable BOTH email and text as options for 2FA. Then, during login, you can select which confirmation mode you want to use. If the text doesn’t work, you can just back up and do the email instead.
EDIT: I tried again and it worked. Not completely broken but not completely reliable apparently.

1 Like

Thanks @travish.3ykfmb,

I wonder if there was some time required on the SSA account for your update to fully process. I appreciate your testing more than once, and hope some others will chime in here :crossed_fingers: so I have some understandable results to send back to all the teams who have been working on this.

1 Like

Agreed. Tried again now and it was nearly instantaneous success–a fraction of a second. I’ll give a few more tries throughout the day and report if any fail.
Edit: Performed multiple tests today with no additional failures. All good so far.


Normally any large enterprise network like SSA or the SMS provider will have multiple servers involved. This is balance the load and provide good coverage over the geographic area being serviced. The changes made would have to roll out to all the various servers … so this could require some time for the fixes to be fully available to all of our users.

  • The actions initiated by Republic Wireless and the results obtained for a problem that spanned multiple vendors including a governmental agency is yet another reason I continue to like Republic Wireless
    • They could have dropped this once it was determined ‘not a Republic Wireless problem’ … but went the extra mile
      :southpawpoms: :star_struck: :southpawpoms:

Text is working for me. Like @travish.3ykfmb, I have enabled both email and text as options for 2FA.
Thanks to all who had a hand in fixing this issue!


As of tonight, at approximately 11:30 PM Central Time, I was able to get both text and email security codes from my Social Security. Apparently, the issue with the text sending of security codes has been resolved. I will continue to have security codes sent to both email and text, in the unlikely event, the issue should arise again. I thank you for keeping up with this issue.


4 posts were split to a new topic: Two-factor codes from USPS not reaching the phone

Message an
Expert customer