My very first republic wireless call. Was this a mistake?

My number finished transferring to RP last night, but I’m afraid to end my virginmobile service yet because I just tried to make a call and it’s not working. It DOES place the call, then immediately says “sorry republic telephony has stopped working”. So the person I’ve tried calling twice is probably wondering why I keep calling and hanging up on him.

Any suggestions?

Dan

1 Like

Which model phone do you have? It sounds like a legacy phone from the error message. I recommend you uninstall and reinstall the updates to the Republic app to try and resolve your issue.

  1. Go to the Play Store
  2. Click on the three little lines on the top left of the screen.
  3. Click on My Apps
  4. Scroll down to the Republic Wireless app and click on it
  5. Click on uninstall and click okay
  6. Reboot the phone
  7. Follow steps 1-4 Again
    8 Click on update

(Note: This step will delete all of the data in the app about data usage and other settings. Also, this will not uninstall the app all the way. Just the updates to the app)

I also recommend the same steps for the Republic telephony app.

1 Like
Message an
Expert customer