Need to reset phone to get LTE data


#1

I have a Moto G5. I’m on the 2 GB plan.


Phone works great on WiFi. When Im out of WiFi, an LTE data network is available, but to use data I need to reboot my phone. Once the phone is rebooted, it works great on LTE data.

Anyone experience this problem and have a solution that isn’t as obtrusive as a phone reboot?


#2

Hi @jyoliver,

@billg haven’t you had a similar experience?

You might try toggling Airplane mode on and back off, as that also refreshes the connection with the cellular network, but doesn’t take as long as rebooting the phone.


#3

Good thought. I’ll try it next time.

I have tried turning on/off cellular data but that doesnt seem to work.


#4

Another thing to consider is are you actually losing LTE data…or simply the LTE notification on the symbol.


#5

I’m thinking you might be a GSM subscriber like I am. My S7 does this as does my relative’s G5+. I researched this at T-Mobile where their subscribers have the same complaint. Turns out it has nothing to do with the phones and everything to do with their tower registration. T-Mobile says we need to reboot our phones, especially if we have moved from one tower to another… I tried the Airplane mode trick as did my relatives. It didn’t work for us.

I think this is happening when we move from one of their older towers to one of their newer VoLTE band-12 towers. At least this is when I usually experience it.


#6

#7

Nice, thanks for the heads up. Not really sure how to handle this in my area.

Actually, this happened while I was on the road in some major metropolitan areas (Phoenix, SF) - so I’m wondering how to truly debug the issue.


#8

This has happened to me on 2 different Nexus 5x devices. One ended up a brick due to hardware defect so never got resolved. The current device hasn’t recovered since it started doing it. Airplane mode sometimes works but when you turn it on you have to wait till it says no cell service before toggling back.
Reboots rarely have more effect than airplane mode. Even factory flashing doesn’t improve it. Wish there was a way to force a tower refresh or something.
Edit: This started after traveling. 200 miles away. Finally changed from roaming to LTE while I was there. Now I have LTE when I return to that location, but pulling teeth to get LTE at home.


#9

I often see full bars and no LTE at home. When the T-Mobile tower fades away my phone connects to an AT&T tower. Lots of bars, emergency calls only. WiFi solves the problem for me.


#10

So I researched further and you are dead on. The problem is the device switching from band 12 to band 2. 12 is LTE only and runs VoLTE. It also runs at a low frequency, which is why it works indoors. Band 2 runs LTE data and voice over GSM. I watched today as my 5x was sitting at -86db on 12, then just switched to 2 and was running at -109db. Once it kicks you onto band 2 the only way back to 12 is resetting the radio. Reboot or airplane mode toggle are the 2 options. Toggling cell data has no effect because the gsm leg is still alive for voice. Any device that isn’t VoLTE certified gets kicked from 12 by TMobile. So don’t flash a rom if you want band 12.


#12

First, I’m well aware that Nexus 5x has had VoLTE for some time. If you flash a rom it is no longer certified. It’s seen as a different device. If you don’t think that is accurate then feel free to drop Pie on the 5x and watch RW app reject you and not have VoLTE.
Second, my phone DID always use band 12. That’s the only reason I didn’t reactivate the CDMA sim from my first 5x. When the T-Mobile SIMs first hit republic I had to switch back to Sprint SIM just to get signal.
Band 12 should be a fallback for areas with great band 2 or 4, but where I am you may as well use the post office before using band 2 because your message will get there faster.


#13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.