New Moto e4 won't talk to Google Wifi


#1

My new Moto e4 phone has trouble connecting to my home Wifi (Google Router, Spectrum Cable, Arris Modem). It connects slowly, disconnects often, but always reconnects on its own. When connected, web page downloads (Chrome) or app downloads (Play store) are extremely slow, and do not complete. I can monitor the progress on the Google Wifi app on another phone and see it is downloading data but at snail’s pace (0.03 Mpbs). It never makes calls over Wifi, but works fine calling on Cell. However, voicemail won’t download. This is the second e4 I have received. The first would not activate. This one had a brief, 1 hour period when it connected with fast data rates during which it activated. Afterwards. dialed * # * # 8647 # * # * at direction of Republic help, and phone said it was not activated, even though it makes and receives calls. Has anyone seem similar problems or can suggest a solution. Before you suggest, read the following that I have done:

  • Rebooted Wifi router and modem several times
  • Done a factory reset
  • Done a cache wipe
  • reset network settings
  • Forgot wifi settings and reconnected several times
  • Checked the Republic suggested phone settings
  • Worked through the community “maximizing your wifi” tips and tricks

Note that my home Wifi works flawlessly with a large number of devices, including 8 family owned Republic Moto phones (only two others in the house presently), all which show excellent wifi connections everywhere in the house (per Google app) and 35 Mbps download rate. They all connect immediately when entering the house, or when rebooting the modem and routers, and almost never spontaneously disconnect.

Finally, this phone appears to work well in one other wifi system I have tested, in very limited testing.

I would welcome any suggestions. Republic help is out of ideas.


Will Google WIFI Router work with Spectrum
#2

Wow, you don’t leave much un-done (and great documentation provided)

  • I did find one hit where the E4 wouldn’t connect to a router that was set to channel 12 (but worked on 1-11 which are the only valid channels in the US)
  • Have you tried to set it to either 2.4 GHz or 5 GHz Only and see if you can connect (rather that having it in automatic)
  • Have you tried it on your home router with all other devices off? (incase an older B/G device is causing a problem)

#3

Just a shot, but have they asked you to ensure that Bluetooth is turned off on the phone? Or do you have any active Bluetooth connections anywhere in the same environment? There are some known interference issues that can occur between Bluetooth and 2.4GHz WiFi.


#4

Unfortunately, if this is a Google Wifi system as stated in the subject, the user has no control over channels or controlling which radios are in use.


#5

Thats a bummer … any idea how they manage adjacent and same channel interference from neighbors?


#6

The system is constantly monitoring itself, the performance of attached clients, and neighboring wifi and changes channels on a sort of supposedly uber-intelligent “auto” basis. There is no user control, at all.

The Google Wifi devices are quite the opposite of Android. They’re sealed up tighter than your average Apple product.


#7

This is a Google WiFi, so I can’t alter much. I did shut off the guest network, which made no difference. I also turned off Bluetooth as suggested below, and again, no difference. I have not yet tried turning off all other devices on the network. That will take some work.


#8

Now that you and @louisdi have helped me understand (a bit more) Google WiFi … turning off the other devices, and the setting of the Android to use a single freq would still be valid test to try.


#9

I turned off or disconnected all other devices on the network, and there was no change in performance of the e4.
How do I set the phone to use a single freq?


#10

I’m afraid I have more bad news. Google removed the setting to choose which WiFi band to use on the phone with Android 7 Nougat.


#11

Great … more Apple like with each release :frowning_face:
So is the E4 already at 7.0?


#12

Yes, it was released with Nougat.


#13

The holy grail is plug it in and it just works. Apple’s arguably had more success than most with that approach and Google seems to be emulating that approach. Clearly, it’s not the best approach in all circumstances. Apple and Google probably would argue it’s best in most. Ironically, Apple’s Airport routers are considerably more configurable than Google WiFi.

7.1, actually.


#14

Now if the Android code would just ‘tell’ @richardr.bebb7b why it will not connect … or at minimum provide what it found lacking/wrong with the signal/connect sequence :roll_eyes:


#15

It’s interesting the issue is limited to an E4 (he mentions other Republic phones connecting without issue). I have an E4+ (bigger battery, bigger screen but otherwise pretty much the same phone) in the household but lack a Google WiFi to attempt connecting it to.


#16

I have similar symptoms. I’m trialling an E4 plus at the moment and use Google wifi at home. All other devices are fine, but the E4 keeps dropping off the WiFi, then trying to reconnect, then dropping off again. Indicated network strength is 66%, so not a range issue.
When I go into WiFi in settings on my phone it sometimes says ‘authentication problem’, sometimes says ‘connected, no internet’ and sometimes works fine.
If I switch the phone off and on again, it usually connects fine
I’m on the latest firmware on my WiFi and latest version of android on the phone
Have I got a dodgy device? Any other ideas?
Cheers!


#17

That was my problem, only I almost never got a connection where I could
download data over the wifi, even though the phone said everything was
connected. The phone worked fine on other networks, and one day, it worked
fine on my Google Wifi, but only when I was outside the house, and it was
choosing 2.4 GHz connection. All other devices, including a range of
Republic, Moto phones worked perfectly. A second, new E4 gave similar
symptoms. Republic has had this problem with other customers, but hadn’t
been able to reproduce it to test it. Finally I replaced my phone with a
G4 and it works perfectly, the first try.


#18

Add me to the list. Here’s what I sent the help team.

I have a 3 node Google Wifi mesh LAN. I upgraded my phone to the Moto E4. Now, I am unable to connect to the main SSID. It attempts to connect , but is usually in the getting ip address mode. If it does connect, data transfer from the Internet doesn’t occur. HOWEVER, if I connect to my guest network, everything works. FYI, my previous Moto G worked fine on the main SSID and all 30 other IOT devices work fine on the main SSID. This has me flummoxed.


#19

After much research on the web, this appears to be a common problem with the E4. I did everything richardr.bebb7b did with the same results. Now, how do I get my money back for the defective product?


#20

Hi all,

Thanks for sharing your experiences.

We want to take a deeper look into what is being reported, so thank you to those that have already opened a support request!

I’ve done some testing with an E4 on our single node Google WiFi system here in the office, and it works successfully thus far. For sake of clarity (and hopefully narrowing down the issue), do each of you currently use the 3 node Google WiFi system?

If so, I would be interested to see if you experience the same issues with your Google WiFi system limited down to just 1 node.

I personally have a 3 node system at home, so I am planning on taking an E4 home to do some testing over the holiday. If we find some information that may be helpful, I’d be more than happy to pass that along to Motorola and/or Google.

Thanks again for bringing this to our attention!