New Moto e4 won't talk to Google Wifi


I have similar symptoms. I’m trialling an E4 plus at the moment and use Google wifi at home. All other devices are fine, but the E4 keeps dropping off the WiFi, then trying to reconnect, then dropping off again. Indicated network strength is 66%, so not a range issue.
When I go into WiFi in settings on my phone it sometimes says ‘authentication problem’, sometimes says ‘connected, no internet’ and sometimes works fine.
If I switch the phone off and on again, it usually connects fine
I’m on the latest firmware on my WiFi and latest version of android on the phone
Have I got a dodgy device? Any other ideas?


That was my problem, only I almost never got a connection where I could
download data over the wifi, even though the phone said everything was
connected. The phone worked fine on other networks, and one day, it worked
fine on my Google Wifi, but only when I was outside the house, and it was
choosing 2.4 GHz connection. All other devices, including a range of
Republic, Moto phones worked perfectly. A second, new E4 gave similar
symptoms. Republic has had this problem with other customers, but hadn’t
been able to reproduce it to test it. Finally I replaced my phone with a
G4 and it works perfectly, the first try.


Add me to the list. Here’s what I sent the help team.

I have a 3 node Google Wifi mesh LAN. I upgraded my phone to the Moto E4. Now, I am unable to connect to the main SSID. It attempts to connect , but is usually in the getting ip address mode. If it does connect, data transfer from the Internet doesn’t occur. HOWEVER, if I connect to my guest network, everything works. FYI, my previous Moto G worked fine on the main SSID and all 30 other IOT devices work fine on the main SSID. This has me flummoxed.


After much research on the web, this appears to be a common problem with the E4. I did everything richardr.bebb7b did with the same results. Now, how do I get my money back for the defective product?


Hi all,

Thanks for sharing your experiences.

We want to take a deeper look into what is being reported, so thank you to those that have already opened a support request!

I’ve done some testing with an E4 on our single node Google WiFi system here in the office, and it works successfully thus far. For sake of clarity (and hopefully narrowing down the issue), do each of you currently use the 3 node Google WiFi system?

If so, I would be interested to see if you experience the same issues with your Google WiFi system limited down to just 1 node.

I personally have a 3 node system at home, so I am planning on taking an E4 home to do some testing over the holiday. If we find some information that may be helpful, I’d be more than happy to pass that along to Motorola and/or Google.

Thanks again for bringing this to our attention!


I have Google Wifi system with 3 nodes.

I recently upgraded to an E4 and experienced the exact issue. Republic replaced the phone with the same model, but the issue continued. Republic upgrade me to the Moto E4+ and while not as frequent I have already started to experience the same behavior.

It is frustrating and I don’t know what the best next step would be.

Would Republic be willing to move me to a different model that does not have this issue with Google Wifi systems?


2 posts were split to a new topic: Replying to closed tickets - no longer supported



Members need to open new tickets now, rather than replying to closed ones. I’ve moved that conversation here: Replying to closed tickets - no longer supported so it doesn’t derail this thread, but wanted to repeat @rolandh’s advice since your suggestion remained in this thread.


I hope everyone had a wonderful Thanksgiving weekend full of delicious food & joyous family!

I have some good news & some not so good news.

The bad news is - I was able to recreate the issue where the Moto E4 will connect to my 3-node Google WiFi system (and shows connected) but doesn’t provide a data connection.

The good news is that I was able to pull logs from the phone while it was in this state. Hopefully Motorola will be able to identify what is causing the issue & can resolve it via a future software update. Additionally, when I removed 2 of the Google WiFi nodes from my network (thus dropping it down to a 1-node system), I was no longer able to recreate the issue.

I know this isn’t a good “workaround,” so hopefully Motorola can get this one resolved quickly!

I’ll make sure to keep everyone updated when we hear back from Motorola on this one!



I am considering a Moto E4

Thanks for the feedback into the forum, it is good to see a user experienced problem re-created and acknowledge by RW. I wonder if there would be some value add if you guys could also let the Google WiFi router folks know of the problem?


I think it could be beneficial. Truthfully, I’m not sure how much the Google WiFi team will be willing to do with it, but it certainly can’t hurt to have both parties notified!


Any update?


My feeling this will only be fixed by action from Google WiFi. For anyone attempting to utilize the Google Router in its 3 device mesh network, I would suggest that they provide google with a report of their failure.

  • I do not have 3 units, so am not aware of what data that the app might provide, but hopefully you can provide them with enough information to get them interested.


Sorry for the delay in getting back to you!
We haven’t heard back yet from Motorola or Google on this issue. Given how close we are to Christmas & New Years, we likely won’t hear anything definitive from either party until sometime in 2018.
I’ll continue to update this thread as we go.


Over the next week I’ll be implementing the Linksys Velop three node mesh system as my house. When I do, I’ll try and get my hands on an E4 to see if this is a Google Wifi unique thing or if the E4 has issues with other multi-node system.


Thanks @louisdi - I’ll be interested to see the results!


@richard.p I can now confirm that the E4 works perfectly with the Linksys Velop 3 node mesh system. Using an E4+ graciously lent to me by @southpaw, I was able to test that the E4 connects and moves between nodes (I have a 3 node system and I watched it seamlessly transfer between each node as I moved around) as it should.

The phone behaves precisely like my S8 when connecting and moving between nodes.


Thanks @louisdi - Good information to have!


I have a Verizon Moto E4 that was having this exact same problem - all my other devices work on my Google Wifi network just fine but the E4 (two of them, actually) just wouldn’t connect. What ended up working for me was creating a “guest network” within the Google Wifi settings that only the E4s are using and they have both been consistently connected for two days now. Seems dumb, I know, but it’s working for me so I wanted to share the info and I hope it fixes the issue for others.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.