New moto g5s plus doesn't have cellular network


#1

What phone do you have? Moto G5S plus

What plan are you on? my choice

Does your plan include data, or just talk & text? includes all

I’m seeing this as a regular problem in 2017, but I’m not seeing final answers.

I just bought a moto g5s plus from motorola through their sale, and I bought the sim card through republic wireless. I activated the phone no problem, and assigned my existing phone number to the new phone (so now the old phone doesn’t work/isn’t activated).

I left the house for the first time today, dropped off my son and told him to text me when he was done. Little did I know that I didn’t have any cellular service! No phone, no text, no data. I’m not sure what’s going on? My old moto g 1st generation didn’t have any problems, and we bought my hubby a moto g5 plus through republic wireless in January-ish 2018, and he hasn’t had any problems.

Can someone please help me? I did open a help ticket (#1412377).

I just get nervous as I use my phone to keep contact with my kids when they’re out and about.

Thank you so much!


Issue Description


Moto g6 vs moto g5S plus - please help me decide
#2

Hi @tanyar.shuz3w!

Could you provide a ZIP code for us? Does your phone show any bars in the cellular status indicator? As to the ticket, agents will respond to you as soon as they can. Republic has recently been experiencing higher-than-normal ticket volume so it may be a little longer than normal. In the meantime, we will do our best to see if we can diagnose your problem :wink: .


#3

my zip is 91104.

I currently have 3 republic wireless phones on my account. My hubby and I both had moto g 1st generation phones before he upgraded in January, and I am upgrading today.
Of the 5 phones we’ve used with RW, this moto g5s plus is the only one that has a problem.


#4

oh, and yes I do have some lines in the cellular triangle icon


#5

Ok. Have you tried rebooting your phone?


#6

yes. twice


#7

Ok. I checked the coverage and it looks to be ok so that shouldn’t be the issue. Next, I would recommend clearing the cache. Here is a link: How to Clear the System Cache on Motorola and Nexus Phones – Republic Help . Can you send calls and texts over WiFi?


#8

I’m not sure what magic you did, but things are working!! Thanks so much!


#9

Congrats! You got it up and running! What exactly did you do? Please make sure to close your support ticket you opened to help out Republic support.


#10

I restarted it one more time after you told me, and something happened. Maybe it just takes time to fully activate? My next step was going to do the cache like you said.

My next issue is to figure out why my notification sound isn’t working on my text. tee hee. If it’s not one thing, it’s another!!


#11

Something is always broken with technology :wink: . Is your phone muted by any chance? You can go I to settings, then go to sounds and you should be able to set the volume.


#12

yes - technology makes life easier…and also harder! lol. :grin:

My volume controls are all on


#13

Can you hear the ringer for calls?


#14

yes, it comes in for calls


#15

Ok. Try rebooting into safe mode and have someone send you a text. Safe mode will disable most third party apps to check if they are causing issues.


#16

in safe mode.
no sound from text still, so I guess it’s not a third party app?


#17

That would indicate that it’s not. What texting app are you using?


#18

Messages.
Came as the default on the phone. I’ve used it on the old phone and it worked well. I know hubs has it on his moto g5 plus and it works well there too


#19

Hmm… Have you checked for a software update? Additionally, open up the messages app, go to the app settings (three vertical dots in the upper right). Make sure the “Notifications” lever is checked and make sure a sound is selected for the “Notification sound”.


#20

it says it was updated 7 hours ago