New phone - Incoming calls using wifi, outgoing calls using cell network

master_ticket

#1

Samsung Galaxy J7

My Choice Plan + 1GB

Includes 1GB Data


Issue Description

I’m moving on from my ailing Moto X. Yesterday I got my SIM card in the mail and activated my new Samsung Galaxy J7. Definitely will be an adjustment periods, but I’m happy.

Today while making some calls I’ve noticed that all of my outgoing calls are defaulting to the cell network. Found this a little odd. Played with handover settings on the Republic app, mainly toggling on and off handover on my home wifi network. With either option it defaults to the cell network for outgoing calls. Turning off cell data, it still defaults to the cell network.

However, for incoming calls it defaults to “Republic Network,” or wifi.

I know Republic is all about wifi first, and that’s basically the philosophy I’ve tried to keep for the entire time I’ve been with them. So if I can change something, I will.

That said, so far at least the call quality is good, so it doesn’t make a big difference to me in terms of call experience. I can hit manual handover, and that does work with no interruption. However, I’m probably not going to do that every time I make a call, in all honesty.

Is this by design? Is this how “Adaptive Coverage” works? Is this something I should even be worry about, or trying to correct? Just seems odd to me that outgoing and incoming calls behave differently.

Any help appreciated.


Poor call quality since June 6 related to June 6 "Activation" issues?
#2

No. Calls should be using wifi 'Republic Network" by default.

I’ve been noticing this too lately. with my Nexus 5X. Outgoing call always using Cell.


#3

Hmm. Bug in the RW app? Put the phone in Airplane Mode which will turn WiFi and Cell off. Then Turn WiFi back on. Will it call out on WiFi this way?


#4

I tried this just for fun when I read the OP. I had a solid arc, then placed a call…phone said “Cellular Network” when the call went through. I turned airplane mode on, then wi-fi on, and tried to place a call…phone said “Radio Off”, and the call wouldn’t go through. I could access the internet though. Galaxy S7 Edge, just call & text plan, CDMA.

edit: when I’m in Airplane Mode, and my wifi is on, my RW notification says "Calls over cell, messages and data over WiFi. I must have some wifi issue I’ll have to figure out. Guess it’s good I tried this out. LOL


#5

OK, I tried this on my Samsung S7. With Airplane Mode ON and WiFi ON outgoing calling works just fine.


#6

I have GSM. 4.0 plan Nexus 5X

Put in Airplane mode, wifi on, Solid Arch, call went though fine on Republic Network.

Turn Airplane back off, wifi/data on, normal use, all outgoing calls use Cell network. I can manual handover fine via the notification.

I still have the ver 3.19.1.1 R.W app.

EDIT: My mother on 2.0 plan/phone. auto Wifi outgoing calls working fine


#7

My experience just now was the same. Airplane mode on, Wifi on, and when I made a call it used the wifi network.

After turning airplane mode off it worked on Wifi … on the first try. I made two more test calls and those both went to the Cell network again.

:scratcheshead:


#8

done some more testing.

Unable to get Auto Cell to Wifi handover to work.

Wifi to cell is working fine. (after forcing handover to wifi)

Odd thing. As I know it auto switched before alot.
Nothing has changed with the phone, or wifi network.


#9

With Airplane Mode OFF an outgoing call says “Republic Network” which I think means WiFi.

My cell service at home stinks. I had 0 bars with the LTE so at least I had some cell service.


#10

Yes. “Republic Network” means it is using wifi to call.
If u have the manual handover notification enabled, it will say “handover from wifi to cell”.


#11

Here are my Handover settings:

image

The selected WiFi network is my home 2.4 GHz SSID.


#12

My calls are going out via cell. Incoming calls via WiFi. Likely a temporary RW system bug we are seeing and will be back to normal soon.

:flight_departure:


#13

I have the “Allow manual handover” setting enabled. As it describes, that gives u the notification I mentioned.

And also yes, my network is selected in the network list as well.


#14

Maybe. I rebooted my router, I voip-ed my phone, rebooted, deleted and reinstalled RW app. I give up. I already spent all afternoon changing passwords all over the place because stupid Twitter had some glitch and warned everyone to change passwords. LOL I think the next step is throwing my phone against the wall. But I’ll wait.


#15

Bah. Twitter. I don’t care much. I have 2FA on all my accounts, so even if someone has my password…there out of luck, or have to do whole lot more work to get into my account.


#16

Hi @anthonyd.osfjjs,

Thanks for bringing this to our attention. We have a team looking into the matter right now. By design outbound calls should be going over Wi-Fi if the network can support it, but it does appear something is not working as designed at this time.

For anyone in an area with poor cellular coverage experiencing difficulty placing calls, please put the phone in airplane mode, then re-enable Wi-Fi. This will keep the outbound call on Wi-Fi despite this current glitch.

When we have a resolution, I’ll update this thread.

We are investigating this as part of Master Ticket # 1374743. Pinging @Ambassadors for situational awareness.


#18

@PlaneTherapist,

Would you mind letting me know which phone(s) you tested?


#19

@southpaw,

X Pure, G4 Play on GSM and G4 on CDMA. Same issue on all.

:flight_departure:


#20

Huh, thought it was just me. Look at me, accidentally bug reporting.

Good to know it should be sorted out.


#21

WiFi Calling Issues - http://status.republicwireless.com/incidents/bqdtjj4sjpdm

Incident Report for Republic Wireless

Investigating

We are currently investigating reports of phones being unable to initiate calls over WiFi. We’ll provide updates here when we have more information. We apologize for any inconvenience this has caused and thank you for your patience.

Posted 44 minutes ago. May 05, 2018 - 17:48 EDT

This incident affects: Calling.

← Current Status

@anthonyd.osfjjs,

You paid attention, asked a good question and got some attention. Thanks.

:flight_departure: