"new" phone, no service

Phone says no service.

What phone do you have?
Moto X4, just purchased through Swappa (Mint condition from a power seller with high ratings.) New Republic SIM card installed. Activation completed. Phone service with old phone was fine at this location.

What plan are you on?
My Choice + 1 GB

Does your plan include data, or just talk & text?
1 GB of data.


Issue Description

Have rebooted phone, turned Airplane mode on, then back off. Disabled, so I am not free to leave the house tonight to check to see if I get a signal elsewhere, although I will be able to do that in a couple days…but I hope to have it fixed by then as it’s my only means of communication if something happens while I’m out of the house.

Hi @genie86333,

I’m sorry to see activation hasn’t gone smoothly on your new phone.

I’ve double-checked, and it does look like the right SIM card for your area was selected and sent to you.

Do you still see “no service” when the phone is on WiFi, and will the phone make or receive calls or texts on WiFi?

Sometimes if there’s no cell signal when you’re activating, all it takes is rebooting the phone when you are in a location with cell service for this to resolve. And sometimes all that requires is going outside.

Other things to try:

and if those don’t help, this last one will make the phone forget your saved WiFi networks, but it won’t make the phone lose any other personal content.

If none of those steps resolve the issue, the next thing to try is moving to an area where you know you have good cell signal and reboot.

Yes, I can make calls over wi-fi. I just noticed something odd though…it says, even when I’m calling over wi-fi that I’m calling via the Republic Network, even though it shows no service. Tried turning off wi-fi & it tells me I have to turn off Airplane mode to make calls (double & triple-checked that Airplane mode is off. and it still says the same thing.)

I will take the other steps & see if any of them fix it. Thanks.

1 Like

So none of those steps worked…I will have to try going somewhere where I have service in the next couple days. I did notice something when I was going through those steps. I noticed a spot that said “Sim Status” in the settings & tapped on it. It says Mobile Network State: Disconnected. Service State: Voice Radio Off / Data Radio Off. Could that be something causing the issue &if so, how to fix it?

I hope someone else will chime in, because I have to sign off, but see if you can find the “Device help” or “help” app already installed on the phone and look for the hardware test for mobile network. See if that reports any hardware problem.

You might also try running the diagnostic in the republic app on the advanced settings.

Hi @genie86333 ,

You say you have a Moto x4. :thinking:
If it’s the 32GB model (versus the 64BG), you can try booting your phone into safe mode to see if things improve.

Wouldn’t run the Device Help diagnostic because it says I need to turn mobile data on - I check, mobile data is on…go back to the app, it says I need to turn mobile data on. I tried the Republic diagnostic and it just told me basically what we already know - that there is no network connection & suggested I try reinserting the sim card. (Which I did, with no resolution.) I’m done for tonight…worst experience ever with a new phone. :frowning:

32 GB. Already tried Safe mode, but thanks for the suggestion.

Also opened a ticket…was told to try a factory reset without installing 3rd party apps. That didn’t solve the issue either. AND although it says it’s charging, it’s not charging…last night, I thought it was dead because it wouldn’t turn on, but when I tried 5 minutes after putting it on the charger, it said it was at 100%. Great, not sure why it didn’t turn on at first. BUT since then, it’s gone progressively lower, even though it was on the charger all night. When I woke up, it was at 20%. Tried using the charging cord that came with the phone…10 minutes later it was down to 17%. I’ve finally turned it off & we’ll see if it charges at all that way. Also, I’ve discovered it reboots randomly AND every single time I take it off the charger. That’s a royal pain. 99.999% sure it’s going to end up being a return, even if going for a drive tomorrow shows the no-service issue is just at my home (I don’t think it is.) Guess I’m paying more for a brand new phone…Swappa has left a very bad taste in my mouth.

Message an
Expert customer