No android Keyboard on Moto E 1st Gen - need help


#1

Hi, I got a Moto e 1st Gen. I mistakenly uninstalled the Google “Gboard” app. Now, I have no keyboard. I can’t install a the app from the play store because I only have google voice and the play store will not allow me to use the voice input to speak text into the search box. Hence, I cannot install any keyboard. What can be done?

Thanks for any help.


#2

FYI the play store text box says “Google Voice typing cannot be used for this field”. This is why I can’t reinstall anything.


#3

Hi @tepper,

Using a computer, sign into the Google Play Store with the same Google credentials you use on your phone, and go to https://play.google.com/store/apps/details?id=com.google.android.inputmethod.latin&hl=en_US. You can use the “install” button to send the app to your phone.


#4

Hi,

Thanks. I tried to do this from my chromebook, but it installs the Gboard app on my chromebook and does not give me the option to send to the phone when I click “install.” Must this be done from a PCWindows machine?


#5

Someone with a chromebook would have to answer that, I"m afraid I don’t know. Do you use the same Google credentials on both the Chromebook and phone? If you now click the “installed” button does it show you both devices?


#6

Same credentials on Chromebook as on my phone. There is no “installed” button after installing. The only buttons are “Uninstall” and “open” when viewed on the Google Play Store on a Chromebook.


#7

Are you following that link through a browser? (Not opening it in a Play Store App?)


#8

Yes. I am.

FYI - I have just gone to a pc and repeated the procedure. There, I can get an “Installed” button. I am now trying to send to my phone as you instructed. I will reply on this thread if it works.

I find two things unfortunate and surprising:

  1. That the Google Play store works better on a Windows PC than on in-house Google Chrome OS software.

  2. Android Lollipop on Moto e 1st Gen allows the user to accidentally uninstall the primary input device - the keyboard - making the phone partially unusable.


#9

Thanks. Your suggestions worked.


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.