No calls or texts on cell

What phone do you have? Moto G5 Plus

What plan are you on? My Choice + 1GB

Does your plan include data, or just talk & text? 1GB data


Issue Description

Suddenly without warning I cannot make or receive calls or texts on cellular. Everything works on WiFi.
When making a call over cellular I receive the message: TURN OFF AIRPLANE MODE TO MAKE A CALL. The airplane mode is not on. I have turned it on and off to test.

Other things I have tried that did not work:

  • I have restarted the phone.
  • I removed and reinserted the SIM card.
  • Reset to factory settings.
  • Reactivation (using asterisk#asterisk#8647#asterisk#asterisk) Followed by rebooting
  • Wiped Sprint settings (using asterisk#asterisk#72786#asterisk#asterisk) and then update the device config
  • PRL update
  • Started in safe mode

The top of the phone says NO SERVICE.

Do I need a new CDMA SIM card?
Is there something else wrong?

Hello @amandah.s67way,

This could be a payment issue. If you look (login) here:

https://republicwireless.com/account/
Do you see a notification of a billing issue?

If your account looks good, let us know and we’ll continue to troubleshoot :slight_smile:

Looks good to me. The other phones on the account have no issues and it’s all set up on auto-pay.
Screenshot_2020-10-18 Phones Republic Wireless

Thank you for checking :slight_smile:

Ok, let’s start troubleshooting by going to the Device Help app:

and running the hardware test for mobile networks.

Does it show something like this?

1 Like

Unfortunately I cannot get past a prompt. It reads "Do you agree to turn on your mobile data for the testing? " When I click yes it takes me to the settings where my data is already on. I’ve tried turning it off and back on and returning to the hardware test but it’s just a huge circle of the same.

I found this thread on the Motorola Community board. Same issue as you:

Moto’s responses were to try the Hardware Test (like I had you do), and failing that, a reset of the phone (which you did).
After that It was recommended to send the phone in for repair. :confused:

1 Like

Hi @amandah.s67way,

Is the phone reading the SIM card? If you open the Republic app, tap the Settings gear :gear:, and tap “About” does it show an ICCID and SIM card type?

On the Help tab of the republic app (the encircled question mark at the top), if you run the diagnostic test, what errors does it report?

The phone is reading a sim card in the Republic ap. Yet, in the diagnostic test i see this:

1 Like

Have you tried reseating the SIM card?

I’m glad to send a fresh SIM card to you, but I’m concerned this may be a hardware problem. There’s also a chance it’s a local tower outage.

I’ll reply to you in your Help Ticket to get some additional details and get that SIM card order processed.

1 Like

Looking elsewhere on the internet I, too believe it’s a hardware issue. I think I will just cancel service and chalk it up to bad luck.

1 Like

Update: Unfortunately it appears to be a hardware failure. I tried new SIM cards to no avail. RIP to my Moto g5 Plus. :skull_and_crossbones: :iphone: Thank you to everyone who took time to read through this offer assistance. Republic Wireless was fantastic, as usual. They got right on my ticket and checked in regularly.

5 Likes
Message an
Expert customer