No cell/data connectivity

Moto G Power, 3.0 plan. GSM SIM.

Over the weekend, I changed out my SD card. The SIM popped out, and I accidentally reinstalled a CDMA SIM that was in the collection of “stuff.” No idea why I even have it still, but I digress. I got a nasty error when I powered up the phone, and I quickly realized my mistake. Out with the bad SIM, in with the GSM SIM (which has been working fine until now).

I am in a dead zone (hence RW!), so I didn’t realize until I headed out today that I don’t have any cell service. No data either…empty triangle with the dreaded “x.”

Here’s what I tried:

  • resets and re-activations
  • full phone reset (yup, I did…regretting it now)
  • got myself to a “known good” location with an excellent signal from tower
  • verified a good signal by looking at my wife’s phone
  • put the SIM in an old phone. I was able to connect to the tower and make a call
  • no issues at all with wifi calling.
  • phone thinks I have a GSM SIM installed, and RW app diags are happy (except for no cell service when I’m home)

Still nothing. It just seems that T-Mobile doesn’t want to talk to my phone. Am I locked out somehow? If the GSM SIM was bad, the test with the old phone would also fail. Do I have a hardware failure?

Head scratcher. Thanks.

Have you tried restarting your phone when in the dead-zone? There is an area between two towns where I live where cell service is non-existent if you just ride through the area but magically appears if you restart the phone in the dead-zone.

If the sim card was bad you would get sim card errors when you turn the phone on.

Yes. Inside my home is dead. I get one bar outside.

Anything of concern here? IMS?

The only thing I can think of is to try refreshing your activation again.

Edit: Also might be good to power the phone off and try reinserting the sim card.

Phone information screen:

My radio is on. The "VoLTE Provisioned” setting is enabled, but grayed out. Not so on my wife’s phone. I can toggle her setting.

Seems like something’s stuck?

You mention “resets and reactivations”. Did that include a network settings reset? If not:

Yes…network settings and full phone reset.

As I mentioned, the SIM works in my old phone. My G Power appears to recognize it (no errors, etc). Just seems that T-Mobile wants nothing to do with me!

What precisely was this nasty error. The worst case scenario should be being advised the SIM was invalid.

Did you try restarting the phone and/or a network settings reset while in this area of known excellent signal?

Is your wife’s SIM GSM? Have you tried activating it in your Moto G Power? Alternatively, do you have a fresh GSM SIM available?

Just to confirm, you activated the SIM in this old phone using Republic’s mobile app?

As a hail mary, you might try a factory reset without restoring anything. I’ve had one situation that required such a thing when doing a SIM switch between providers (not Republic Wireless, though).

Yes, invalid SIM. I guess I was a bit dramatic in my description!

Just got back from a location with a good signal. My wife’s phone was LTE, with a full triangle. Zip for me. I rebooted, restarted, did the “8746” thing, etc.

I took out the SIM in my G Power and put it in an old Moto E phone. Connected to the tower, and I was able to make a phone call. I could try my wife’s SIM in my phone, but my concern is that there’s something wrong with my phone, and it will damage her SIM. Then we’d have two phones down! I’ll have to think about that.

I did request a replacement SIM.

I just tried the SIM from my wife’s phone. No dice. All testing points to my phone.

So, it could be a hardware issue.

Before I pursue that (■■■■), is there a chance that my phone is not being recognized by T-Mobile, so I’m essentially locked out? Some sort of provisioning error?

recap:

  • my new phone, my SIM: no service
  • my old phone, my SIM: service
  • my new phone, my wife’s SIM: no service

I activated the phone info screen (4636) with my SIM in my current phone, and then installing it in my old phone. Note the difference with the “VoLTE provisioned” setting. It’s enabled and active in my old phone, and grayed out in my new phone. Is this a concern? a clue?

Candidly, I think you may be overanalyzing this a bit. Republic 3.0 phones support VoLTE and though greyed out the slider is in the on position.

That moving your wife’s SIM did not work does suggest the problem is on the phone rather than with the SIM but trying a new GSM SIM is still worthwhile.

Meanwhile, and I understand you’ve previously done so, if it were my phone, I’d try a network settings reset where I knew cell signal to be strong. A network settings reset in an area of weak signal often fails to solve the problem.

Thank you, sir. I am off to find a decent signal!

No luck. Same empty triangle with the “x”

I will try the new SIM. If it’s still an issue, then off to Moto for repair.

11/2 update.

The RW team sent me a GSM SIM and a CDMA SIM (thank you!). I use GSM, so I tried that first. No luck. Just for yucks, I installed the CDMA SIM, and…it worked! So, it seemed that the phone was mostly ok. Maybe the GSM radio frequencies were fried? Maybe the infamous “stuck bit?” One way to find out…

I pulled out the CDMA SIM and re-installed the GSM SIM. To my surprise, that worked too! No issues with a 25-minute call. Full triangle, LTE. I made calls too. Surfed the net. Still connected.

Hey, it’s 2020, so anything goes, right?

I still wish knew why the phone would not connect for a week+.

Message an
Expert customer