No cell service

#1

Moto G4 Plus

I have not had cellular service on my phone for 3 days now and I am in a place which has coverage. (My husband has service on a Republic phone and is right next to me) I have received one response on my help ticket and it did not fix the problem. (I reset the network settings and refreshed the republic wireless activation)

Republic customer service has been unresponsive to my ticket for over 24 hours. It seems like my service was just turned off randomly.

Has anyone else had this issue and able to get it resolved? Did you just switch carriers?

Super frustrated with Republic for not providing the service I’m paying for and for having unresponsive customer service. When big problems happen, you need to be there for your customers.

#2

Different Republic phones may be provisioned for different cellular coverage. It’s entirely possible for the coverage on your husband’s phone to be different from yours. More here: Republic Wireless Coverage – Republic Help.

I’m very sorry to hear this. If you would be kind enough to share your ticket number, I’ll ask staff to take another look.

2 Likes
#3

The ticket number is 1286663

Here is the only response I received from Republic. I followed their instructions, told them they did not work, and have not received any other responses.

Jordi N.
Jordi N. (Republic Help)

Dec 16, 9:09 PM EST

Hi Toni,

Thanks for contacting us about the issues you’re having with cellular service on your Moto G4 Plus. I can imagine how alarming and frustrating it is to have such a sudden and complete loss of service, especially when there’s another phone that is getting service right next to you. We would like to work with you, so that together we can find the source of the issue and fix it. With that in mind, we have some preliminary troubleshooting steps that may clear this issue immediately.

The first of which is to perform a network settings reset and follow that by ensuring the defaults are then set to the necessary requirements to run our services. We have a couple of Help Center Articles that will guide you through this process:

How to Reset Network Settings for 3.0 Motorola and Google Phones on Android 7.1
How to Confirm Basic Network Settings on 3.0 Motorola, Nexus, and Alcatel Phones Running Android 7.1 Nougat and Below

After performing this, we would also like you to refresh your Moto G4 Plus’s Republic Wireless activation. This will ensure the phone is properly synced to our services and runs a check on another few basic settings to run our services. We have another Help Center Article for this step:

How to Refresh the Republic Wireless Activation

With both of these actions completed, take some time to test out your phone and see if you’re still having the same lack of service. If you are, please let us know as soon as possible, as well as responding to the following questions:

Has the start of this issue coincided with anything specific happening to your phone? Any new apps, software, or damage to your phone?
What does your phone’s cell service indicator look like when you have no service? Any odd notifications or symbols?
Is this lack of service affecting your ability to text and access cellular data as well, or is calling the only thing affected?

Answering these questions will better help us determine the source of the issue you’re having and guide us towards fixing the problem.

Thanks,
Jordi

#4

Hi @tonik,

I’ve asked staff to look in on your ticket. I would just like to confirm that in addition to alerting them that neither the network settings reset or refreshing your Republic activation resolved the issue, you answered the questions at the end of the response you were kind enough to refer to?

1 Like
#5

Hi @tonik,

I’m advised staff has eyes on your ticket.

1 Like
#6

i performed the network settings reset and refreshed the republic activation and neither resolved the issue.

#7

Hi @tonik,

Thank you for the additional context! I understand what you are saying, however, the Republic agent working your ticket also asked some follow-up questions, which we can see from the interaction you posted. Specifically:

I wish to confirm, you also responded to those questions as doing so would hopefully speed resolution for you.

1 Like
#8

yes, i also responded to those questions. here is my full response:

I reset the network settings and
Refreshed the republic wireless activation and still do not have service.

The start of this issue has not coincided with any new apps or damage to the phone. The signal symbol looks like an empty triangle. The lack of service is affecting my texting as well.

What should I try now?

#9

Hi @tonik,

I understand you wish to get this resolved as soon as possible as would I. While the Community is a great resource often able to help with these type of issues, our attempting to do so while you work with staff would likely be more hindrance rather than help. I’ve made staff aware of the circumstances and been assured someone is looking at your ticket. I’m confident you’ll hear from them. Meanwhile, I just wanted to confirm you had answered their questions also, so support wouldn’t repeat them.

1 Like
#10

Just updating this thread because I’ve seen multiple people posting about this recently having the same issue.

I received one more response from Republic telling me to reinstall my SIM card (which did not help) and to send them some screen shots of certain things on my phone as well as locations I go to frequently. I did this and it has almost been another 24 hours with out a response from them.

If anyone else having this same issue resolves it faster, please post here.

1 Like
#11

tonik,

Is this a new phone to you? Has cell worked since initial activation? Thanks.

#12

If Republic staff is asking for locations where the phone is used frequently, they are evaluating coverage at those locations. I appreciate the wait has been much longer than one would want, however, if coverage is the issue, the Community won’t be able to solve it for you. I’ll advise staff that its been nearly another 24 hours since you’ve last heard from them.

3 Likes
#13

I’ve been having the same issue. Had two of the same phones for 4 months and they worked great. We did an update to both phones and now we don’t get any cellular coverage where we had previously had no problems. We can only call when using wifi. I tried reinserting the sim card, it seemed to work on the one phone for a few hours, then no go.

#14

We are having a similar problem. Hope it is o.k. to tell our problem here, as I have no answer for you.: Our new-2- phones have no cellular service, even though they say we are on Cellular! We can get onto WiFi, but even still cannot call out! We can receive calls fine, but cannot call out on either WiFi or Cellular service! Is there any way to get physical help with our phones, like at Walmart? We purchased our phones, (Alcatel) on line from a Republic ad! The phones came timely, but we cannot get them to work on Cellular service. I ordered the $30.00 service, as that was the lowest priced service shown for our new Alcatel Android phones. We were happy with our $10 service with old phones, which were gradually going bad. We want only talk & text, but things keep happening, like some game downloaded while my phone was plugged in at night. HELP!!

#15

First you should change you plan to the $15 basic call/text plan now offered with the new My Choice plan. That would be equivalent to your previous level of service. This can be done using the RW app on the phones.

RW doesn’t have call in Support but you can open a Support ticket that should be able to address your lack of service. Help Ticket | Republic Wireless

closed #16

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Message an
Expert customer