No Cellular Service - RW App Says to Install SIM Card


#1

What phone do you have?
Moto E4 (two phones)
What plan are you on?
My Choice + 1 GB
My Choice Talk & Text
Does your plan include data, or just talk & text?
One phone yes, the other no.


Issue Description

I have two Moto E4 that have no cellular service. Problem started this morning on both. The cellular signal strength icon is missing, Republic Wireless app give message to install SIM card, and I keep getting notification to update system software. Neither phone can make or receive calls. One phone has Republic Anywhere installed and it can text. The other phone has default texting app and cannot text. Email, browser & other apps work over WiFi.

On one phone I have tried a few thing:

  • Restarted phone. Didn’t fix problem.
  • ##8647## - Nothing happened. Numbers I entered disappeared, but dialer app stayed on screen.
  • Installed system software update when prompted. It went through install process and rebooted. Then it prompted me to install system software update again. I didn’t install again.
  • Removed and reinstalled SIM card. No change, Republic Wireless app still tells me to install SIM card.

I’ve done nothing to the other phone except restart it.

I opened a ticket this morning and I’m still waiting to hear back… Any help would be appreciated.


#2

You will need to install each update. They are consecutive. There may be several.


#3

Have you tried reseating the SIM card?


#4

You should install all updates until it says there are no longer any available. The final update should resolve your issue. (It generally takes at least 2 updates.)


#5

Thanks for your help. I installed four updates on one phone and three on the other. Everything seems to be working now.


#6

Ah yes, the Patient image fixes yet another one :smirk:


#7