"No Network Connection" on lock screen; building a solution with Macrodroid?

I thought things were better, but this afternoon it happened again. Here are the screen shots of my lock screen and the logs.

image

Here is what I see (please confirm each # line, as some of that confuses me)

  1. It looks like you left the house and went on cell at 07:48 and then returned to WiFi at 08:29?
  2. What happened between 08:29 and 15:50 when it looks like Doze kicked in?
  3. During the 15:50 event, it didn’t turn on the Display, which might indicate a MD failure or possibly you didn’t battery de-optimize the MacroDroid app?

OK.

  1. During this time I was out taking a walk.

  2. This was regular around the house stuff. I did some vacuuming if you must know!

  3. The screen shot was taken at 3:58 (this was edited out by the moderator) and I took the log shots immediately after. I think I was reading a book when I picked up my phone and noticed the message. I have confirmed that both the Republic app and the MacroDroid app had battery optimization turned off.

Let me know if you would like me to try something else.

As neither the 15:50 or 15:58 Trigger completed, I wonder your changing your Notifications or Permissions may be contributing to the results were seeing?

  • Could you Uninstall the MacroDroid App (Press/Drag to top of screen and drop into the Uninstall/Trash can.
  • Re-install from Macrodroid and accept all Permissions and make no changes to Notifications … this hopefully will give us a clean start. Then if works we can adjust the Notifications … if it doesn’t work, we will at least know a few more things it isn’t

OK. Uninstall, reinstall complete. Accepted all permissions. I will let you know.

1 Like

A post was merged into an existing topic: Phone displays “No Network Available” after most recent RW App update

jben - Had another event. Screen shots of my lock screen (with personal info removed) and both logs are attached.

I realized later that, because of the uninstall/reinstall, the MacroDroid app did not have Battery Optimization turned off. I have now turned that off and will let you know if that makes a difference.

@ronf.cd82t5,
Dropping WiFi when Android goes int Doze or Deep sleep is part of Androids design to limit battery drain.

OK. Here is the information from the latest event. The Battery Optimization was off for MacroDroid.

I think I have tried all the variations you suggested. Let me know if you have other ideas.

ok, thanks … I need to take a break … we are in the middle of changing out a bunch of dumb switches to smart ones (at this point they are smarter than I am)

@jacklone did you come up with a fix? I’ve had the same issue for weeks.

No fix yet. I think I am on to something promising, but I have to do some more testing. Stay tuned.

1 Like

@jacklone,
Good to see one of us thinks they are making headway … I honestly haven’t had any luck on figuring out a variation that would make it work for you, but haven’t given up either :slight_smile:

Unfortunately, what I thought was working last night is, in fact, not working. I am stumped.

So we’re still peeling back the onion one layer at a time … so goes troubleshooting :frowning:

  • What did you prove didn’t work? Please share, as that can sometimes be very valuable information

I thought turning off Battery Optimization for Google Connectivity Services might have an effect, but no cigar. Another poster said they turned off Battery Optimization for all the apps and still had the problem.

1 Like

It came back… Lost service triangle… Now what?

Get BlueMail for Android

Did you load and test the macro I built and published in this other discussion?

I’ve only loaded the step by step as per your email to me yesterday…

Get BlueMail for Android

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Message an
Expert customer