No network connection


#1

Phone: Google Pixel
Plan: My Choice + 1 GB
Plan includes data


Last week I purchased a Google Pixel to replace my Moto X Pure. I realized that I could move the SIM card from the old phone into the new phone (although I realized this after I ordered a new SIM card, so that is in the mail still). I was able to make a call over my car Bluetooth yesterday with no problem. However, today, when not connected to WiFi, I’m getting an alert in the notification pane that reads “Republic Wireless. No network connection. You do not have access to cellular networks. Try to find a WiFi network.”

I do not get this alert when connected to WiFi, since I obviously have service through that WiFi connection. Where one would usually see bars for service, my phone shows an empty triangle - no bars, no LG, no exclamation point.

Any ideas? Did the SIM card change in some way between the Moto X Pure and the Google Pixel, in which case using the new SIM card when it arrives would fix this problem, or is it unrelated?


#2

Can you take a look at the SIM card and tell us if the word “Republic” is in all gray/black or if the “public” part is in green?


#3

The “public” part is green.


#4

Then the SIM should move without issue, and so that likely isn’t the cause. Please try the following steps to resolve this issue:

  1. Reboot the phone in an area that has a strong cell signal. (Some people have simply needed to step outside and reboot.) If this fixes it, stop.

  2. Please open the dialer (as if going to dial a phone number) and enter *#*#8647#*#* The screen should clear, when it does, please restart the phone. If this fixes it, stop.

  3. This one is more complicated. This step will clear out any saved connections for Wi-Fi and Bluetooth that you may have already made. We’re going to reset the network settings.
    Go to Settings > Backup and Reset > Network settings reset
    Read the warning, tap “Reset settings.” You will be warned a second time. Tap “Reset settings” to confirm. The process will usually take 5-10 seconds and the cellular signal bars icon will go away for a moment. Once the cell signal bars icon returns, you should reboot the phone.


#5

None of these steps resolved my problem. Do you have any other tips?


#6

When I look at the Republic app on my phone, it shows my correct number and identifies the phone as a Pixel, though when I look at my Republic account in a browser, it shows my device still as the Moto X Pure. I don’t know if this has any effect.


#7

That may just be a timing problem, but I would open a Ticket with Republic Help … let them know what you have done and the results


#8

This is likely at least part of the issue. Generally, step 2 of @louisdi’s 3 step process would resolve that particular anomaly. You might try uninstalling, then reinstalling the Republic app.

If that fails (and this were my phone), I’d go ahead and activate the new SIM moving the number from old to new SIM. In theory, swapping a Republic GSM SIM from the Moto X Pure to the Pixel should work. That said, theory and reality are often two different things. For this reason, Republic would suggest activating a new SIM when switching phones as best practice.


#9

When I uninstalled and reinstalled the Republic app, it had me do some of the activation steps again, although this time it also had be install the Republic Anywhere app in addition to other steps. I installed that app, and upon restart I now have a notification showing an alert triangle on top of two M’s. It says “Phone Services. Phone not allowed”. Any ideas about this bit? (Thank you for all your help!)


#10

Hi @cathyw.o9wv6w,

Candidly, at this point, I’d stop trying to make the SIM from the Moto X Pure and your new Pixel get along. I fully appreciate it should work and I’ve moved GSM SIMs between Republic phones mostly without issue but on occasion it just doesn’t work.

I’d return the SIM to the X Pure to test that it worked there. Then, I’d go ahead and activate the new SIM in the Pixel opting to move the number from the X Pure when that opportunity is presented. Republic’s activation documentation is here: Activate Your Phone – Republic Help.


#11

Well, I moved the SIM back to the X Pure, it worked there, and I tried it again in the Pixel just for kicks - and I have cell service. I don’t know if the card maybe wasn’t seated perfectly before (though it doesn’t seem like there’s much wiggle room there), but everything’s functioning now at least.

Thanks for your help!


#12

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.