No notification sound when receiving text messages

What phone do you have? moto g7 power

What plan are you on? choice

Does your plan include data, or just talk & text? includes data


Issue Description

phone rings, receives texts, but no sound when I receive a text, sound works when I receive a text using WhatsApp, but not regular sms messages app. ??

Assuming you are using Messages by Google app

  1. Open the Messages by Google app
  2. Tap on :dots: -> Settings -> Notifications
  3. Tap on “Other Notifications”
  4. Tap on “Behavior” and select the right sound behavior as per your preference.

You may need to repeat the steps…but in step 3 select… “Incoming Messages” if you want to customize that one differently.

Thank you Amitl, but that still doesn’t work. ??

I am also having the same problem with my Moto G7 play (1 gig plan). Someone else has been trying to help but the issues has not been solved. Thought I would tag along to this thread to see if there was a solution here.

1 Like

Hi @phylliss.a80e8k, while it’s great to read along on topics similar to the issue you’re experiencing, let’s make sure we focus your troubleshooting in the topic I’ve created from your posts: Moto G7 Play no notification sound when messaging app is closed

Sometimes when two people try to troubleshoot in the same topic it becomes quite confusing, and troubleshooting across multiple topics guarantees you’ll be asked to do the same steps over and over!

1 Like

Hi @johnb.7fad6b,

Please tell us what messaging app you’re using that isn’t making a notification sound. Is it putting a notification icon in the notifications tray at the top, left of the screen when a new text message is received? Is the phone vibrating when a new text message is received?

Do you have WhatsApp set as your default messaging app?

Is do not disturb enabled?

1 Like

I’m using the messaging app that came with my moto g7 power phone. I
do have WhatsApp installed and it does make a sound when I get a text.
I did not make it my primary messaging app. I do have do not disturb
active (to stop telemarketers), but I chose the option to allow
messages to override the “do not disturb” function. The standard sms
app does show a notification at the top of the screen, but just no
sound.

Do you have “do not disturb” set to disable just sound, or sound and visual notification?

Hi Southpaw,
I have the custom option chosen, but nothing checked.
Thanks for the reply.

If you don’t mind posting a screenshot of your Notifications screen for Messages…we might be help you debug further.

Amitl,
I’m not sure what you want. ?? When I get a regular sms text, a
small screen pops up in the upper left-hand side of the home screen
with a picture and says “mark as read or reply” and then it
disappears. I also turned off “do not disturb” to see if that would
allow a sound. It did not.
John

In this other thread it was noted that…changing the default sound to something else seemed to be a workaround…so that’s definitely worth a shot.

Amitl,
Thanks. That didn’t work either.

Hi @johnb.7fad6b,

Let’s see if I can pull everything together and make sure my testing duplicates what you have done.

  1. Do not disturb is enabled.
  2. The Messages app is set to override Do Not Disturb

  1. When you send a text message and your screen is on, you get the “heads up” notification that allows you the option to mark the message as read, or reply.

The part I’m not following is this:

I can’t find a settings menu that this seems to describe, could you provide tap-by-tap instructions to help me find it?

With my phone set with Do Not Disturb enabled and Messages set to override Do Not Disturb, I do not get a sound notification. I think this must be a shortfall of the Messages app, because I do have other apps that are able to override Do Not Disturb.

I was, however able to get the Messages app to notify with sound by making a change in the Do Not Disturb settings menu.

Open the Settings app.
Tap Sound
Tap Do Not Disturb
Tap SMS, MMS and Messaging apps
Select the option you prefer - if you want all your text messages to make a sound, pick “From anyone”

However, you’re also having another issue that I cannot replicate.

This makes me think the phone may also be in vibrate or silent mode. press the volume button and you will see a slider bar appear on the right-hand side of the phone.

Above the slider you’ll see a bell icon (shown), a vibrating phone icon :vibrate:, or a “no bell” icon (a bell that is slashed out.) Which one do you see? Tap it until it shows the bell icon. Does that change the behavior at all?

Dear Southpaw,
Sorry for the delay, but I’ve just spent the last hour,
approximately, trying to find that menu where the “custom” option
appeared. I couldn’t find it, but I know I’m not going crazy. It was
there.
The good news is that I found the setting I needed to get the
messages app to make a sound. I had been trying to solve this problem
by going into the “sound” menu under general settings, not the message
app menu. When I went in there, I was able to find the settings you
mentioned. The missing link in all of this is that the needed options
are “hidden” under the “Incoming messages” tab, which has a box that
was already checked so I never looked “inside” that option. When I
clicked the “Incoming messages” tab, I found the behavior and override
options. That solved the problem.

Thanks for your help. I really want to like this phone so I hope the
new SIM card will solve the reception problem.

3 Likes

Hi @johnb.7fad6b,

I actually just found the “custom” setting myself, but I’m glad to see it doesn’t seem to be a factor here! :crossed_fingers: that you’re on the way to having a phone you can enjoy!

Good to hear you sorted it out…that’s what I was trying to convey earlier…but I agree it is not very intuitive.

Yeah, the fact that the “box” is already checked and there is no
“hint” that one needs to click on that option to reveal the other
options. That’s why I kept skipping over it!

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer